LightDM doesn't show password field at login screen

My lightDM doesn’t show a password field at login. Here is how it looks like.


If I want to get the password field, I have press up and down arrow keys which show the password field field again.

I have tried changing the slick greeter settings but nothing works. I couldn’t find any help online regarding this. Can anyone help?

Install lightdm-gkt-greeter and see if that fixes the problem.

sudo pacman -S lightdm-gtk-greeter lightdm-gtk-greeter-settings

Next enable lightdm-gtk-greeter.
Use your favorite text editor, and edit the following file.
/etc/lightdm/lightdm.conf

scroll down past “General Configuration” on down to “Seat Configuration” and then to the line

[Seat.*]  be sure you come to [Seat.*] as there is a similar line before it

About sixteen lines below this is the “greeter-session” key (lightdm calls the config settings “keys”) look for

greeter-session=lightdm-slick-greeter

Now comment this line out by adding a # at the beginning

#greeter-session=lightdm-slick-greeter

Reboot and it should boot with the lightdm-gtk-greeter

This will at either fix your problem or indicate the problem is maybe not lightdm-slick-greeter
If it fixes your problem, use lightdm-gtk-greeter-settings to set your background, move the password entry box around the screen, etc.

Pudge

3 Likes

Thanks a lot @Pudge!!. Changing to lightdm-gtk-greeter solved my issue. It has a password box.
So I guess the problem is the lightdm-slick-greeter?

1 Like

Yes, lightdm-slick-greeter seems to be kind of finicky about hardware.
It’s been my experience that lightdm-gtk-greeter will work on just about any hardware as well as Wayland.

Also, with gtk-greeter you can use the settings GUI to move the password box anywhere on the screen to work around your background image. If the background’s main point of interest is right in the middle, then move the password box to not cover it up.

Pudge

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.