Libwacom 1.4 update breaks xbox controller input

Latest update of libwacom from 1.3 to 1.4 has made my (wired) xbox controller stop working in Fallout 4 completely, the steam controller continued ok as did the keyboard.

I downgraded to 1.3 (using the downgrade package from aur) and it works again.

I haven’t seen anything on the Arch forums (I read it every day) and searching libwacom doesn’t result in anything useful.

I don’t know why a wacom tablet file would mess with an xbox controller so I first tried to remove libwacom but it is a dep of libinput so I stopped there.

I also tried booting with the LTS kernel with no success.

Have you tried to downgrade libwacom? You can do that e.g. with program downgrade.

Note that downgrading is only a temporary trick until upstream has fixed the issue.

More info about its development:

Arch package page:

@manuel Have you tried reading my post lol ?? Coz that’s what I did and that’s what I said I did :innocent:

Sorry, I didn’t read your post fully (did you update it while I was answering?). :wink:

No I finished with it about 10 minutes before you replied, no worries, I just thought it was funny :stuck_out_tongue:

1 Like

Problem found and resolved in libwacom 1.4-2

And it’s reported on the Arch forum now with more details:

great to hear that. was about to suggest reporting the issue, the libwacom devs move pretty fast.