Libvirt brings: "Warning: KVM is not available."

I installed virtualization support by installing the following packages:

  • qemu ---- (generic and open source machine emulator and virtualizer)
  • libvirt ---- (API for controlling virtualization engines)
  • virt-manager ---- (desktop user interface for managing virtual machines)
  • ebtables ---- (ethernet bridge filtering utilities)
  • bridge-utils ---- (utilities for configuring the Linux ethernet bridge)
  • dnsmasq ---- (lightweight, easy to configure DNS forwarder and DHCP server)

Afterwards I have added my user to the libvirt-group and enabled libvirtd-service:

$ sudo usermod -a -G libvirt $(whoami)

$ sudo systemctl enable libvirtd.service
$ sudo systemctl start libvirtd.service

Anyhow, when starting virt-manager and trying to create a new virtual machine, I receive the following warning (that I never had before on previous Debian systems):

Therefore I have checked…

$ LC_ALL=C lscpu | grep Virtualization
Virtualization type: full

… what looks fine, but anyhow…

$ lsmod | grep kvm

… does not bring any output.

Where is my mistake? :face_with_monocle: Do I need to install KVM differently on Arch-systems?

I’m just a lowly simple-minded Virtualbox user - but I wonder if it is enabled in your BIOS - like AMD-V needs to be switched on in mine…

You never know what gets skipped :grin:



What is the output of

sudo modprobe kvm_intel


sudo modprobe kvm_amd

Depending on your CPU

To be clear, the output should be nothing. That generally means it worked. If you get output, post it here.

1 Like



modprobe: ERROR: could not insert ‘kvm_intel’: Operation not supported

Reason could be that I receive all those errors because I try to set up a virtual machine in a virtual machine? :grin:

I just wanted to check if I discovered all required Arch packages to set up an EOS like I need it on a “real” machine, so I checked this in a VM-playground first.

Yeah, if you want to do nested virtualization, that requires special handling.

That would have been good information to provide up front.

1 Like

Thank you for your great help!

Okay, good to know that! I thought that the VM does simulate a “real” machine as close as possible, so I was confused about this error.

I am sorry for that! Still in learning proces… :wink: