Librewolf PGP importig keys error

Hello, I tried downloading Librewolf using

yay -S librewolf-bin 

and getting the following error message. I have Canada and U.S. mirrors and updated them just now via the welcome app.

[Aur:1] librewolf-bin-94.0-1

:: (1/1) Downloaded PKGBUILD: librewolf-bin
1 librewolf-bin (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: (1/1) Parsing SRCINFO: librewolf-bin

:: PGP keys need importing:
→ 031F7104E932F7BD7416E7F6D2845E1305D6E801, required by: librewolf-bin
==> Import? [Y/n] y
:: Importing keys with gpg…
gpg: keyserver receive failed: Server indicated a failure

Any help or steps to resolve would be greatly appreciate it.

Try importing the key manually as described here:
https://wiki.archlinux.org/title/Pacman/Package_signing#Adding_unofficial_keys

option 1 didn’t work which is pacman-key --recv-keys keyid

I don’t understand option 2 pacman-key --add /path/to/downloaded/keyfile

with the first option, still receiving the same error:

gpg: keyserver receive failed: Server indicated a failure
→ problem importing keys

You probably need to use a different keyserver. Try using keyserver.ubuntu.com

1 Like

When I searched on the link above, I get Not Found message.

The key I searched is 031F7104E932F7BD7416E7F6D2845E1305D6E801

When I review the gpg.config file, I only see the following:

no-greeting
no-permission-warning
lock-never
keyserver-options timeout=10
keyserver-options import-clean
keyserver-options no-self-sigs-only

should it include other links or something?

Try adding/changing this line to /etc/pacman.d/gnupg/gpg.conf

keyserver hkp://keyserver.ubuntu.com

added using sudo nano /etc/pacman.d/gnupg/gpg.conf

and still not luck. I also tried removing the gnupg file using sudo rm -r /etc/pacman.d/gnupg and then reinstalled sudo pacman-key --init and then sudo pacman-key --populate archlinux and still no luck.

I ended up downloading the flatpack version from pamac for now.

after adding ubuntu and few others to the list, I now see the following errors when trying install the bin file.

/etc/pacman.d/gnupg/gpg.conf:7: invalid option
/etc/pacman.d/gnupg/gpg.conf:8: invalid option
/etc/pacman.d/gnupg/gpg.conf:9: invalid option
/etc/pacman.d/gnupg/gpg.conf:10: invalid option
/etc/pacman.d/gnupg/gpg.conf:11: invalid option
/etc/pacman.d/gnupg/gpg.conf:12: invalid option
gpg: keyserver receive failed: Server indicated a failure
==> ERROR: Remote key not fetched correctly from keyserver.

This is the config file…

no-greeting
no-permission-warning
lock-never
keyserver-options timeout=10
keyserver-options import-clean
keyserver-options no-self-sigs-only
keys.openpgp.org
pgp.mit.edu
keyring.debian.org
keyserver.ubuntu.com
attester.flowcrypt.com
zimmermann.mayfirst.org

Remove all those lines you added and add the line I provided above. Put that entire line in the file.

still no luck :frowning_face:

when I type sudo pacman-key --recv-key 031F7104E932F7BD7416E7F6D2845E1305D6E801

I get the following error

gpg: keyserver receive failed: Server indicated a failure
==> ERROR: Remote key not fetched correctly from keyserver.

I was successfully able to install using the following:
yay -S --mflags --skippgpcheck librewolf-bin

PGP import key error:

Create a .conf file in /home/username/.gnupg with name dirmngr.conf
Add keyserver hkp://keyserver.ubuntu.com:80
Add standard-resolver
save and close

Note: :80 is for DNS related. If it doesn’t work with 80 then remove and try again by running killall dirmngr in terminal.

Now it all works finally after reading and trial and error from various forums :slight_smile: