Libreoffice spellcheck not working

On Windows for some reason libreoffice has spell checks working just fine but on Linux it doesn’t work at all. I believe this may have to do with missing extensions but then how come on Windows it exists but not on Linux?

Anyways I am looking for English Australian spell checks, anything I can do to get it working?

Install hunspell and hunspell-en_au.

A tip for the future, you can see the list of optional dependencies for any installed package by passing the -Qi option to pacman. :wink:

EDIT: fixed the typo, sorry about that :slight_smile:

1 Like

unfortunately hunspell-au doesn’t even exist in the AUR :frowning:

Cool mate, so like do I type pacman -Qi libreoffice-fresh?

I had similar problem recently. If you download the relevant language pack for Libreoffice, this doesn’t enable the spellcheck function. Try downloading the relevant Australian English dictionary from:

In Libreoffice menu open Tools/Extension manager, select the downloaded file, then restart Libreoffice


Sorry, it’s hunspell-en_au, it’s in the repos.


Thanks but I think @Kresimir suggested easily using terminal :slight_smile:

Precisely… and there you see that is uses hunspell for spell checking. And then you can look up language packages for hunspell:

pacman -Ss hunspell
1 Like

Thanks bro :slight_smile:

1 Like

That;s how I got mine to work.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.