Libreoffice Crash on Video Playback

I almost sure it is not eos fault, but just asking to be sure, apologies in advance

i have also made a screen recording -

Can someone help, i have presentation with a video file (i know it is a bad idea, it is not my idea to add it, one of my professors presentations), and when i present it in libreoffice-impress, when i reach the slide with video, libreoffice crashes, and a window with possibly the first frame of video opens, libreoffice window becomes unresponsive, and does not close with libreoffice close shortcut, or window manager shortcut (sigterm), i have to KILL it, the videos themselves all are originally mp4s, with video codec being AVC (264) audio in AAC (though there is no audible data is present), i tried to look online, but could not find similar crash, i have all of the required gstreamer stuff installed, it is libreoffice-fresh(24. (i also tested with onlyoffice, there also the video does not play, only a black box, but video controls come, i found similar bug reports online), i have also tested with a fresh libreoffice config

Version: (X86_64) / LibreOffice Community
Build ID: 420(Build:2)
CPU threads: 8; OS: Linux 6.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

12345678910pacman -Ss gst- | rg installed
extra/gst-libav 1.24.1-2 [installed]
extra/gst-plugin-pipewire 1:1.0.5-1 [installed]
extra/gst-plugin-va 1.24.1-2 [installed]
extra/gst-plugins-bad 1.24.1-2 [installed]
extra/gst-plugins-bad-libs 1.24.1-2 [installed]
extra/gst-plugins-base 1.24.1-2 [installed]
extra/gst-plugins-base-libs 1.24.1-2 [installed]
extra/gst-plugins-good 1.24.1-2 [installed]
extra/gst-plugins-ugly 1.24.1-2 [installed]

have you tried converting to ogv? - same crash (vp9+opus)
i am not sure if it an arch thing or an upstream thing
it works fine in online ms office
do you have any debug info in the terminal when it crashes? - i tried to check with gdb, it made a huge file, i could not find much in it
open format - odp version similar crash
so can you vm an office install and export it from whatever app your prof is using?
ldd /usr/lib/libreoffice/program/soffice.bin -

Welcome to the community! :enos_flag: :wave:

Please edit your original post and remove the double explanation of what is happening.

As far as a solution is concerned, please try to see if the issue can be fixed by using OnlyOffice.

yay -S onlyoffice-bin

In case the package fails to build/install, you can download the Appimage directly from their website at

Or use one of the other options: Flatpak or Snap

Sorry for the double, might have pasted a copy, and sorry, but i prefer libreoffice to only office (i have tried it in only office also, i get a black box instead of video, but player controls are visible, i checked online, and this seems to be an old only office thing

No need to apologise. Just asked you to do that for readability. Long posts can sometimes get skipped simply because they are long.

Hmm. Okay. Sad.

In Libreoffice, try turning on hardware acceleration if it’s not turned on. See below:

Tools -> Options... -> View -> Use hardware acceleration

Another option if the above doesn’t work:

  • Select the video
  • In “Custom animation”, click “Add…”, and in the “Misc effects” tab, choose “Toggle pause”. Right click on the animation and choose “Start With Previous”.
  • Add a second “Toggle pause” animation, and leave it on “Start On Click”.
  • Now, when you get to this slide, the video is automatically paused, and clicking will play it.

enabling/disabling hardware acceleration does not help

and i cant select video, because in both edit mode or present mode, it just crashes whenever i touch the slide with video

Out of curiouisty are these videos on your system? I remember when I was at a course once and the teacher was using powerpoint and couldn’t get videos on their system to play and their solution was to upload to yt and it worked

1 Like

yes, they are embedded in the file itself, and i have tried with open formats, and it still does not work, so something is actually broken

Not sure if this has already been mentioned somewhere, but when you say you tried open formats, do you mean you’ve tried converting/saving the whole presentation file as .ODP?

If not, please try it just in case.


Try this:

Right-click the file -> Open with -> 
Select your archiving app -> Extract the video (or all the files)

OpenRaster and OpenDocument files can usually be viewed/opened/edited even without having the “correct” app on your system by just opening them with a file archiver.

Now, this doesn’t/wouldn’t solve the problem of playing the file within the presentation as it was intended, but you could, theoretically, rebuild the file to make it work as intended (in your app of choice).

How? I don’t know how to do it with OpenDocument files (never tried it), but it’s just placing everything on layers for OpenRaster files.

yes i have been able to extract the video, that way only i encoded it to ogv to ensure it is not some bad driver/libreoffice not supporting these formats issue

Okay… Then I’d say you have three remaining things to try:

  1. Try using handbrake to encode and/or reduce the file size, then replace the video within the .ODP file. After which, try opening the .ODP with LibreOffice and playing from within the app.

  2. Another option is to try is to remove the video from the .ODP file with your archiver app, then try to embed or link it again. ← You may get an error about missing media when you open the .ODP file.

  3. And the third option is to recreate it “from scratch” without the video, then try to embed or link it again.

If the above options are things you’ve already done, then great job troubleshooting, but that is where I’d say my understanding of troubleshooting this kind of issue stops.

Hope one of these three options work.

  1. i have done re-encoding, replacing the video, and in a odp

  2. i have tried removing, presentation works without video, but that is not ideal, i dont want to tamper with files others share to present stuff

  3. i do not want to make it from scratch, but even in a fresh odp, adding video crashes for me,

i want to understand why it crashes and not necessarily how to get by with this video this onetime, and i am asking in eos (earlier asked in arch matrix), to see if it is something wrong on my side because i did not find anythiing upstream

1 Like

To test things out on my end, I created an Impress file, embedded a video and linked another, and both played just fine, even after saving the file, closing the app and reopening the file.

Have you tried this to see if there is some fundamental issue with the app, settings, your system, etc.?

If you test this and have no issues, then the file you are trying to open would be the problem (maybe a simple compatibility issue). The size of the video in terms of storage space or the length of the video in terms of playback time could be the cause.

The big video I embedded, as you can see, is close to 600 MB with a length of 19 minutes. The linked video is less than 4 MB with a length of 1 minute. The file takes a while to load due to the size of the video, and the page the big video is on also takes some time to load. But once it is fully loaded, playback starts within 2 seconds when I press F5.

this is what i wanted, how can i check, i have tried removing my libreoffice config, same issue, it happens with both software and hardware rendered, so it is independent of gpu drivers (though i have intel igpu with working va-api, in browsers and working opengl and vulkan in games), what else could be broken

It seems you’ve done everything that you could possibly do.

The file itself could be the issue. Once a file is originally created in M$ Office, there is no guarantee that either LibreOffice, OnlyOffice, and even older versions of M$ Office will open it properly.

This is how these companies purposely make their software and standards — with the intention to force you to use their proprietary stuff and force you to upgrade when they want more money from you.

When things like this happen, there’s simply no way around it. Either make the thing from scratch using an open format (lobby for your school to start using open source) or use the closed format the way they want you to.

Seeing as this is school-related, I’d recommend just doing things their way, though you could still request/lobby for the use of open-source formats and software.