Libre Office and local network

Hi All,
LibreOffice is giving me heartache when trying to open a file on my local network server. I get an error saying that function is not supported on this OS. So I tried setting up a remote service.
No matter what I try when setting up a remote file server, it doesn’t work. I know I must be doing it rong but the instructions are not very clear.
Here’s the route to my server, is this what I put in as the host?
shared folder name is shared
I’ve tried that but no go.
Any help would be greatly appreciated.


Most probably you would need to configure your Firewall to add a service and open a port:

I am not using the default firewall shipped with EnOS so I am afraid I won’t be of any much more help to you. Hopefully you will figure it out by yourself. If not, don’t hesitate to post back nand wait for other members to chime in.

Good luck and welcome to EnOS’ community!

:enos_flag: :handshake:t5:

1 Like

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

On a client computer with x86_64 Ryzen, with EnOS and KDE, and accessing my LAN server via sshfs, I was able to open a file on the server, no problem. The Server is a Enos headless server on a RPi 4.

Please list the hardware and OS for your client and the server as above so we aren’t guessing what kind of setup you have.

First thing to do for troubleshooting this is to disable firewalld on the client computer and see if it works.
sudo systemctl disable firewalld

If I remember correctly, I had to open port 1900 with udp on the client computer to make this work.

All of this assumes the client computer is running on Linux. but it looks like your are trying to access the server via samba.

Again, Welcome.


1 Like

Sorry for the delayed response. Wife had me painting rooms in the house.

The server is a small PC running KDE Neon with a folder shared. Everyone has permissions to do everything in that folder. I can use Kwrite’s open file menu to access a txt file on the server. Everyone has no problem opening files on the server. The only app we are having a problem with is LibreOffice.
At first, I couldn’t even go to the server through the OS file manager and open a LibreOffice file. I would get a grayed out icon in the Task Bar that I could only close.
When I try to use the Open Remote option in LibreOffice, a window opens that says “Nonexistant File”.
I’m sure I have the server connection set incorrectly in LibreOffice. Danged if I can figure out what it wants. I’m assuming it is a Windows share. When looking at the path in Kwrite’s open file screen it shows smb://rick@
Or am I rong about that.