Libgtk-x11-2.0.so.0 missing when using pcsx2(lutris)


Hi, this happens when trying to run a .iso on lutris with the pcsx2 emulator runner. I installed pcsx2 itself and it wont start, instead, on terminal says: instruction illegal (core dumped).

I tried paru libgtk-x11-2.0.so.0but couldn’t find nothing; then i reinstalled the whole gtk2, but nothing changed. How to fix ?

Try installing lib32-gtk2

1 Like

I did, now the error message doesnt shows up, but i still cant run pcsx2 neither in lutis or pcsx2 itself ( pcsx2 still gives the “cored dumped” thing, what does it mean ?)

Core dump means it crashed.

1 Like

Well, kinda figured out the problem. I went to pcsx2 documentation (https://wiki.pcsx2.net/PCSX2_Documentation/Compiling_on_Linux), got all the missing libs from this list:

lib32-alsa-lib lib32-bzip2 lib32-libjpeg lib32-glew lib32-nvidia-cg-toolkit lib32-portaudio lib32-sdl lib32-libaio lib32-wxgtk3 lib32-soundtouch lib32-libpcap lib32-zlib lib32-libsamplerate sparsehash fmt

and after all that, tried to compile pcsx2-git on terminal and some steps further it gave me this: error PCSX2 requires compiling for at least SSE 4.1

Which, from my brief research, it means that my system dont support SSE 4.1 (or something like that, i’m no expert, but heres my specs from inxi -FAZ --no-host | eos-sendlog anyways).

System:
  Kernel: 5.16.8-arch1-1 x86_64 bits: 64 Desktop: KDE Plasma 5.24.0
    Distro: EndeavourOS
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A88-M v: Rev X.0x
    serial: <superuser required> BIOS: American Megatrends v: 1101
    date: 03/16/2012
CPU:
  Info: quad core model: AMD Phenom II X4 850 bits: 64 type: MCP cache:
    L2: 2 MiB
  Speed (MHz): avg: 1100 min/max: 800/3300 cores: 1: 800 2: 2000 3: 800
    4: 800
Graphics:
  Device-1: NVIDIA GP108 [GeForce GT 1030] driver: nvidia v: 510.47.03
  Device-2: Generalplus GENERAL WEBCAM type: USB
    driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org 1.21.1.3 driver: loaded: nvidia
    unloaded: modesetting resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce GT 1030/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.47.03
Audio:
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel
  Device-2: NVIDIA GP108 High Definition Audio driver: snd_hda_intel
  Device-3: Generalplus GENERAL WEBCAM type: USB
    driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.16.8-arch1-1 running: yes
  Sound Server-2: PipeWire v: 0.3.45 running: yes
Network:
  Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee
  IF: wlan0 state: down mac: 16:77:b7:d5:91:0c
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: 10:bf:48:75:7b:6b
Bluetooth:
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
Drives:
  Local Storage: total: 1.03 TiB used: 70.84 GiB (6.7%)
  ID-1: /dev/sda vendor: Western Digital model: WD10EARS-00Y5B1
    size: 931.51 GiB
  ID-2: /dev/sdb vendor: Colorful model: SL300 120GB size: 111.79 GiB
  ID-3: /dev/sdc type: USB vendor: Generic model: Flash Disk
    size: 14.51 GiB
Partition:
  ID-1: / size: 111.79 GiB used: 70.84 GiB (63.4%) fs: btrfs dev: /dev/sdb1
  ID-2: /home size: 111.79 GiB used: 70.84 GiB (63.4%) fs: btrfs
    dev: /dev/sdb1
  ID-3: /var/log size: 111.79 GiB used: 70.84 GiB (63.4%) fs: btrfs
    dev: /dev/sdb1
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 35.0 C mobo: 34.0 C
  Fan Speeds (RPM): cpu: 0 case-1: 2445
Info:
  Processes: 200 Uptime: 39m Memory: 7.76 GiB used: 1.72 GiB (22.2%)
  Shell: Bash inxi: 3.3.12

Unfortunately, the Phenom II does not support SSE 4.1

Have you looked into if it can be built with a lower version of SSE?

1 Like

Well, it seems that if i use older versions of pcsx2, i should be able to workaround of this situation

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.