Less Than 10% Of Firefox Users On Linux Are Running Wayland

I agree because plasma on wayland is still horribly buggy for me on both manjaro and eos (might be nvidia drivers…not sure). Can’t say about gnome coz never used. Also virtual box doesn’t work for me on wayland.

BTW which one do you use?

  • Xorg
  • Wayland

0 voters

It works fine for me, they are maybe some tiny bugs, but if you’re not too fussy, Plasma on Wayland is usable, in my opinion. Not ideal, but certainly not “horribly buggy”…

However, not having a working alternative for Xeyes is a complete Wayland deal breaker for me (Plasma or not), so I’m sticking with Xorg for the foreseeable future.



catclock works fine under Wayland. At least there’s that…

See…they’re working on it! :rofl:

Priorities. :cat2: :mantelpiece_clock:

I use Xorg because I need display forwarding like “ssh -YC …” to run applications on remote machines. This is not possible with Wayland.


GNOME has a pretty great Wayland experience. The only application that’s given me any grief is Steam and that’s just the UI getting sluggish with chat and library being open. This has to do with Valves custom GUI toolkit though.

I wonder if VBox not working is a KDE thing? It works fine on Gnome Wayland.

1 Like

Just using Wayland cause my PC is powered by a 4 years old Ryzen3 2200G. No nvidia drivers for me, so Wayland is the way to go :slight_smile:


My experience: I am running Wayland with Gnome without any issues. The only application that caused me issues was Firefox. It was occasionally locking the whole UI and after a few minutes I could kill it and get my desktop back. During that time everything was frozen.
I stopped using Firefox because of that.
I am using AMD drivers btw…

This is weird. I’m using homemade trunk build and I never saw such problems.

1 Like

Yep, it is rather strange. The first time it happened was when I was watching a youtube video. So I thought maybe there is a bug in the overlay window in relation to Wayland. But then it happened a second time while I was just browsing a page. After that I stopped using it. I have never experienced anything like it with any other application.

On my laptop, I run nvidia+Arch+Wayland+Plasma, have for some six months, maybe more, and never had a problem. On my desktop PC, I run nvidia+EndeavourOS+X11+Plasma because Wayland doesn’t really work well for gaming just yet, at least not on nvidia hardware. I’m quite happy with both setups and use Firefox as my main web browser on both.

Since I’m logged into the same Firefox Sync account, I wonder if I was counted twice, once (in which case, which one?) or not at all.

1 Like

I can also use wayland without any problem on my manjaro and eos kde + nvidia setup but apps like virtual box don’t work well.

Do you run a multi monitor setup? I keep reading that Plasma+Nvidia+Multiple monitors still has it’s issues.
The geek in me is tempted but I haven’t read about a killer feature yet which would make me switch.

It’s been quite some pain to get my setup working, and it’s more or less flawless for years, would hate to break this…

I’d love to switch, but I’m a graduate teaching assistant, and have to share my screen from time to time. Zoom on KDE Wayland still has issues (screen sharing is not supported), probably the only thing keeping me from switching.


I use both. Kde x11, gnome Wayland

1 Like

Using Cinnamon on both notebook and desktop, I’ll be stuck(?) with Xorg for still a long time. But things work and are comfortable, so it’s fine.

Does Zoom screen sharing work on Gnome with wayland ?

I haven’t used Gnome in a while, but as per other users, yes it does. IIRC, it uses some Gnome-specific framework.

1 Like