Lenovo X1 Carbon 10Gen after new installation, system is slow and some apps crashes


I have a new Lenovo X1 Carbon 10 Gen and I want to install Endeavoros with i3 (previously I was using Manjaro with i3) so I downloaded and installed a new version from 0.

Sometimes when the system is booting, in “Started Accounts service”, the computer freezes/crashes, and can’t move forward, so I have to reboot. When I get into the system, and start google-chrome, it freezes and crashes, and becomes nousable, so I can’t use it.

This Lenovo comes with an Intel IrisX graphics card, and from what I’ve read here, it’s advised not to use the xf86-video-intel driver, but if chrome freezes, I can use the settings writted here. I’ve tried it and the same thing keeps happening, so I’m a bit lost on what it could be.

Has anyone tried to install Endeavoros on a Lenovo X1 Carbon 10 Gen and could you help me? Could someone tell me what it could be?

Thanks in advance!

What are the specs of your hardware? Post the link.

inxi -Faz | eos-sendlog

Here it is https://clbin.com/nU944. It’s a Lenovo X1 Carbon 10 Gen.

If I use Firefox, it’s works well, but if I open Chrome, it’s frozen and I can’t use it

This is very confusing as you never mentioned that it works fine on Firefox? Now you are saying it is when you open Chrome? Is it a browser issue or hardware?

Not sure if this is helpful?




As I said, if I try to open Chrome, it’s frozen, but sometimes the system is blocked in the boot, on “Started Accounts service” and seems to be a little be slow. The system power is on balanced

I just downloaded Visual Studio Code, open, and the same like Chrome. It’s frozen and doesn’t respond :thinking:

how did you install these programs…? which packages? using yay and AUR?

the slow boot maybe another problem, difficult to say if all is related. I would try solving one problem after the other. Also your title is confusing. Is EOS installation slow? or did you mean boot time? The way I read it, you mean EOS installation is slow and crashes. Please clarify a bit, I can then change the title for you to attract the right users to help solve the problem.


Sorry, I will update the title.

I always use yay to install the programs with AURs repositories.

When I say slow, I mean the boot time, and the system after a fresh new installation, plus the problem with some apps that crashes, like Chrome, or Visual Studio Code (VSCode is based on electron, probably this will add more clarificaion or can help, I don’t know if it’s related)

I just downgrade the kernel to 5.15.74, and nothing happens, chrome, and vscode still frozen.

Udate 01: I try to remove the xf86-video-intel and install intel-media-driver following this instructions, and the problem persist with Kernel 6.0.1, and this happens


Update 02: Running kernel 5.15.74 with intel-media-driver works well with Chrome, VSCode etc! BUT there is a tearing or strange behaviour when scroll :thinking:

Example: https://photos.app.goo.gl/YMMmSSibATFtqBRm6

Someone using a Intel graphic had the same problem with the apps, kernel and xf86 driver?

I found this post in arch forum


Seems that this is the thing to do. Next could be the compositor. How did you enable picom in your i3wm config? Perhaps it needs additional configs for picom.

Edit: maybe this one last post could be useful…

I removed xf86-video-intel and after that I had no issues and never installed intel-media-driver… I run the same laptop than you… is the issue the same if you run LTS?

1 Like

Are your running a DE with “proper” compositor/renderer? Or also i3wm with only compositor like picom? I think it’s the main issue at this point based on the other posts on arch forum but could be wrong.

To my understanding xf86-video-intel should not be used on newer hardware if I am not mistaken.

Not generally… some chips do not work without the xorg-driver but in most cases newer Gen4 and newer GPUs (GMA 3000 from 2006 and newer) will work better without this package.

i915.enable_psr=0 as kernel boot option for the driver will disable some power saving option that can cause issues with iris hardware… see here for other possible options:


Option "TearFree" "true"

will be a good (X11) option for most intel GPU.

About picom:

I changed the backend to glx in the picom.conf and left vysnc on in that same file and things are looking smooth now. Seems to have fixed the issue.


1 Like

What kernel are you using? LTS or 6.0?

I didn’t change the picom config, I’m using the same config that Endeavouros set on a fresh install and I’m using i3 as a window manager

I m using the latest atm and everything run smoothly

sorry, but what is atm??

I guess: at the moment. Right?
Note that I’m not a native English speaker…