Lenovo T450s thinkfinger/trackpad problem with kernel 5.10.4 & 5

I have two Thinkpads, a T430s and a T450s. Both have Arch installed, the 450s also has an i3 EOS install. Since the first of the 5.10.x kernels arrived, I’ve had some problems with the T450s. Prior to 5.10.4, it would sometimes start lighdm in a very low resolution mode (looked like 640x480 instead of the 19200x1080 native mode). With 5.10.4, it would only start in that mode. Once X started, the resolution would go back to normal, but the mouse pointer would be locked and neither thinkfinger or touchpad would have any effect. Booting using the lts kernal or going back to 5.9.14 both worked without problems, but nothing helped with 5.10.4.

Found a suggestion that problems might be caused by Xf86-video-intel, so I uninstalled it. That helped, but only by making it possible for me to get to a console and shutdown from there (with it installed, attempting to go to a console just resulted in a flashing cursor).

I updated to 5.10.5 yesterday, thought the problem was gone, since the first few times I rebooted, both thinkfinger and trackpad worked. Didn’t last long - the next morning, when I booted the machine, I was back to a non-moveable mouse pointer.

I tried plugging in a USB mouse, which worked, but isn’t a practical solution (quite apart from the fact that the thinkfinger is one of my reasons for using Thinkpads).

Is anyone with similar hardware seeing this problem? Any suggestions for diagnosing and (hopefully), fixing it?

I am a bit confused, are you having a problem with your graphics driver (resolution) or are you inquiring only about the trackpad? Try to write your post a bit more concise starting with your specific problem/question so it is easier for others to help you :grin:

One thing that could help is following this install for debian, section 4 p.18 about the trackpad fix, it may be worth the try. Let us know if it works.

Edit: Debian runs quite an older kernel, I don’t know if the trackpad problem was introduced with the newer kernel. You could always install the 5.4 lts for the time being.

:smile: Sorry for the confusion. I included the information about the low starting resolution because I wasn’t sure if it was part of the problem. Still not sure, for that matter…

Thanks for the reference. Tried it, thought it might have helped, but so far, no joy. I edited the grub command line and booted the system, mouse and trackpoint both worked. So I edited /etc/default/grub to add it to the command line, rebooted, back to the locked mouse cursor. Very strange…

I have made another discovery about the problem - it seems to be a timeout somewhere during the system load. After what seems to be a consistent 3 minute interval (from the Xfce desktop loading), the trackpoint and trackpad start to work as expected. Very strange indeed…

I’ve checked through the journal searching for references to the trackpoint, but other than the fact that there is a 3 minute gap in reporting the trackpoint ready, haven’t found anything.

Whatever the problem, its certainly related to the new kernel - with either 5.9.14 or the lts kernel, the system behaves as it should. For the moment, I’m using the lts kernel, but I would like to narrow the problem down so I can at least raise a bug on it.

Ok, can you perhaps post this (using the code button) just to double check. Since you changed it in grub at startup and the trackpad worked this should make it persistent.

I read about a suspend and trackpad issue on the manjaro forum, could really be that kernel 5.10.


I also have a Thinkpad T450s with the following configuration:

System:    Host: sol Kernel: 5.4.124-1-MANJARO x86_64 bits: 64 Desktop: GNOME 3.38.4 Distro: Manjaro Linux
LENOVO v: JBET73WW (1.37 )           date: 08/14/2019
CPU:       Info: Dual Core Intel Core i5-5300U [MT MCP] speed: 2195 MHz min/max: 500/2200 MHz
Graphics:  Device-1: Intel HD Graphics 5500 driver: i915 v: kernel

I have tried to move to the next LTS Kernel 5.10.42-1 but notice the system will appear to lock up at boot. Specifically

(1) The system appears to stop while displaying the individual service messages on startup (its set to verbose in the boot settings so I can see if a service fails).

(2) After waiting 5 I press the power button and the system goes to sleep.

(3) I press the power button and know I see the Gnome login screen (GDM as the display manager using Wayland). Still I can’t log in as no input or mouse seems to show.

Pretty much I can just switch to Kernel 5.4.124-1 at boot and everything works fine.

So this being said, what happens when you switch to the 5.4 LTS kernel?