Legacy Nvidia Drivers (Nforce 630i Chipset with Geforce 7100 graphics)

I have a computer that I am working on putting endeavor on and use as a home theater/emulation box. I have tried several ways of installing the proprietary NVIDIA drivers for the graphics, as the open source drivers performance hit is enough to make the pc unusable (it is a very low end card from long ago, if you are not familiar). the latest way I have tried is by using the command

yay -S nvidia-340xx-dkms

That particular driver is the latest patch the card will support, and should support that graphics card. after I run the command, everything seems to go smoothly, until I get this error.

/home/dusty/.cache/yay/nvidia-340xx/src/NVIDIA-Linux-x86_64-340.108-no-compat32/kernel/nv-drm.c: In function ‘nv_drm_pci_exit’:
/home/dusty/.cache/yay/nvidia-340xx/src/NVIDIA-Linux-x86_64-340.108-no-compat32/kernel/nv-drm.c:317:30: warning: unused variable ‘tmp’ [-Wunused-variable]
317 | struct drm_device *dev, *tmp;
| ^~~
/home/dusty/.cache/yay/nvidia-340xx/src/NVIDIA-Linux-x86_64-340.108-no-compat32/kernel/nv-drm.c:317:24: warning: unused variable ‘dev’ [-Wunused-variable]
317 | struct drm_device *dev, *tmp;
| ^~~
/home/dusty/.cache/yay/nvidia-340xx/src/NVIDIA-Linux-x86_64-340.108-no-compat32/kernel/nv-drm.c: In function ‘nv_alloc_os_descriptor_handle’:
/home/dusty/.cache/yay/nvidia-340xx/src/NVIDIA-Linux-x86_64-340.108-no-compat32/kernel/nv-drm.c:610:5: error: implicit declaration of function ‘drm_gem_object_put_locked’; did you mean ‘drm_gem_object_lookup’? [-Werror=implicit-function-declaration]
610 | drm_gem_object_put_locked(&nv_obj->base);
| ^~~~~~~~~~~~~~~~~~~~~~~~~
| drm_gem_object_lookup
At top level:
/home/dusty/.cache/yay/nvidia-340xx/src/NVIDIA-Linux-x86_64-340.108-no-compat32/kernel/nv-drm.c:479:36: warning: ‘nv_drm_gem_object_funcs’ defined but not used [-Wunused-variable]
479 | static struct drm_gem_object_funcs nv_drm_gem_object_funcs = {
| ^~~~~~~~~~~~~~~~~~~~~~~
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:277: /home/dusty/.cache/yay/nvidia-340xx/src/NVIDIA-Linux-x86_64-340.108-no-compat32/kernel/nv-drm.o] Error 1
make[1]: *** [Makefile:1868: /home/dusty/.cache/yay/nvidia-340xx/src/NVIDIA-Linux-x86_64-340.108-no-compat32/kernel] Error 2
make[1]: Leaving directory ‘/usr/lib/modules/5.15.2-arch1-1/build’
nvidia.ko failed to build!
make: *** [Makefile:202: nvidia.ko] Error 1
==> ERROR: A failure occurred in build().
→ error making: nvidia-340xx (nvidia-340xx-dkms)

Anyone have any ideas on how to fix it? I’ve been banging my head against the wall trying to get this driver installed both using yay and downloading from the NVIDIA website to no avail. I should also say that I am using the non-nvidia driver version of EOS, since it was giving me guff about it on my previous install

This is not a specific solution to the driver issue but I too have an older laptop with an integrated GPU and a discrete one (AMD APU + ATI). I have found HW acceleration to offer only the same performance as the software decoding while playing HD videos. In my instance, HW acceleration doesn’t even support the newer codecs like HEVC or 4K videos while software rendering do just fine for (most) 4K H264 and 1080p HEVC.

That is one of the things I’m trying to measure with this old PC. I intend to make a YouTube video (or maybe just a blog post somewhere) detailing the difference in performance between different flavors of linux and of course windows. Which I will be writing from the perspective of someone who has lots of experience with windows, but has 0 clue what they are doing on linux.