Launching Davinci Resolve

Hi Guys:

Diligently working on my transition to Linux from MacOS (and Windows too). My daily driver is now EndeavorOS Atlantis on an older system (AMD Phemon II processor with 24 GB ram). My broadcasting studio uses some hardware and various software that is unfortunately no available in any OSS catagory. I have been using Linux (professionally and personally) for over 21 years.

I started working with Blackmagic Design Davinci Resolve and installed it via directions found online for Arch Linux. It installed successfully, but when executing the program I get the following error:

usr/bin/progl: line 30: 2626 Illegal instruction (core dumped) “$@”

if launched from Desktop it does nothing, but checking from terminal the command used was:

progl /opt/resolve/bin/resolve

I am not sure how to satisfy this command and could use help.

The guide I followed was at the following URL:

I also consulted the Arch Wiki entry as well.

Hope someone can help resolve this.

Thanks,
Michael

1 Like

Sounds like it wasn’t compiled right for your system hardware.
Try this:
https://forum.blackmagicdesign.com/viewtopic.php?f=21&t=87681
You may have more luck posting on their forums as well. Here’s some more:
https://forum.blackmagicdesign.com/search.php?keywords=linux+illegal+instruction&fid%

1 Like

Hello: thank you for your response. Alas the suggestions are appreciated. The BMD forum posts you cited are too old. I am not sure, but I am sure others are struggling with these issues. I thank you for this, however since Arch or any distro derived from Arch is not officially supported, BMD seems to ignore these inquiries.

Thanks again and I suppose as a last resort I will post my stuff on their forum. Still hope someone here can help.

BTW: I am really glad they are making the effort to support Linux at all!

1 Like

Same issue on my machine, did you manage to solve?

Thank you!

Davinci Resolve Requires Proprietary drivers for Nvidia and AMD platforms (depending on which GPU you have you just need that companies driver) to function as it needs the GL driver from them. You also might need to use an older AMDGPU-Pro driver as i think the newer one uses ROCM bits which causes Resolve to flat out crash.

The AMDGPU-Pro bits can be complicated on Arch, there has been issues with certain parts for a while now.

The easiest solution is to use a supported Distro such as Ubuntu, RHEL, Cent, or Suse if you require the use of Resolve. Unfortunately for Arch users AMD isnt concerned with us in regards to the pro drivers so itll always be a bit extra work on Arch unless that changes.

1 Like

Didn’t know I needed drivers for both Nvidia and AMD regardless of my hardware setup, I’ve seen a tutorial on YT for the installation and the guy just used pamac to build the pakage and all worked out of the box, that is why I’m super confused.

BTW I am on an intel I9 9900K and RTX 20280 GPU NV164(TU104), and the Archwiki guide page tutorial dosen’t mention AMD drivers for Nvidia GPUs builds. I am pretty sure I have installed the latest Nvidia Proprietary drivers via terminal. I think my eos jurney could vanish just for this and is really annoying, I love this distro and wouldn’t want to leave it behind to install something else. thnks for your reply!

Maybe you can try install it by following this guide (Arch wiki), updated a few days ago. Also, there’s a post on Blackmagic Forum with some additional tips here.

By the way, welcome to EndeavourOs and Formus, I hope you’ll stay here for a long time.

1 Like

Juicy stuff! I will report back Thanks a lot for the celerity, helpful and friendly comment! :hugs: Happy to be a part of this awesome community!

Hi Vax, the resolution was to change to a newer platform (in my case a Xeon processor based system). It seems that a required processor level function was necessary for resolve to run, that was SSE 4,2 support (at the machine level) my other machine supported SSE something but through a ton of research and a support call to BMD found out that this was what I needed to have to use the product.

Hope that helps, I had hoped the old girl would do the job, but as someone once said “The only constant in Technology is change”. So my new machine is almost as old, but is a HP Z400 Workstation. Those can be bought second hand for under $200 USD.

1 Like

I think than my issue could be another, but the result is the same, nothing happens when i try to open the program.

Since I don’t know how to open the app from terminal (and i looked everywhere to fin a command) i don’t actually know my error code, if you can tell me how to do that it would already be a big step forward so I can see the error code, since there is no DavinciDebug.txt to speak of on my machine, and according to the ArchWiki that file would tell me were the problem is.

Also the archwiki guide mentions a similar issue in the troubleshooting section under the OpenCL subsesction, but it’s solution also didn’t work for me unfortunately.

Hello again Vax. Yeah, I can tell you it just showed the error when I tried to run DR. I copied it from my terminal to my post but you might check your Xorg logs and or dmesg logs in /vat/logs if memory serves. The Xorg ones may be in your /home directory ( the one you log into with your non-root user.

Hope that helps.

Cheers and good luck.

FYI I googled the issue before posting to this forum, but much of what you have done is the same.

Michael

1 Like

Found on the Arch wiki, on Troubleshooting section:

Logs location
DaVinci Resolve creates log file '$HOME/.local/share/DaVinciResolve/logs/ResolveDebug.txt' at every launch. If are you having problems, try to inspect it for useful messages.

You can check the log file at ~/.local/share/DaVinciResolve/logs/ResolveDebug.txt and post the contents here, so the experts can take a look and try to solve the issue.

Maybe it’s a good idea to create your own thread, or maybe a moderator can split this one, because the original issue is already solved.

Thanks Triby, I have read through th wiki page but that file dosen’t exixt on my machine as you can read in the post you quoted, the problem is that the only alternative would be to get the terminal to print out an error message I think.

Try to find the executable, maybe it’s located on /opt/resolve/bin/resolve, so you need to execute it from terminal:

/opt/resolve/bin/resolve &

No i mean if you have Nvidia you need Nvidia Drivers, for AMD you need AMDGPU-Pro not both regardless lol

You “should” be fine using Nvidia, you dont have many options besides proprietary drivers. The only thing i can think is maybe are you using a laptop?Could be an optimus issue if so.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.