Latte Dock


I’m having a small issue with Latte Dock, when I install it via pamac, no errors occur, when I run it via terminal, no errors show up.
However when I run it via terminal or via applications, it says that it’s running in task manager, but it doesn’t show up visually.

I’m unsure on where to start with this issue as I’ve done some research but none of the things I’ve found have helped or don’t match my issue.
Has anyone else experienced this?


Have u changed the layout you maybe on the empty one?
I done this as well… Theres a shortcut im not sure what but you can find out in kde settings that will open latte settings.
Then u can add a dock

Hmm, I’m currently using XFCE, perhaps that’s the issue? Do I need to install KDE Settings in order to check this?

Latte dock was built for KDE and depends on lots of its frameworks.
Any particular reason for latte over plank?
If u need latte’s customization power you could try cairo dock it’ll work on almost everything.

Have u got qt installed? But i wouldnt reccomened latte on xfce

Ah OK. I’m currently using Plank and I don’t so much have as a problem, but it’s lacking in customisation. I’ll check out Cairo :slight_smile:


1 Like

Try using the latte-dock-git version in AUR, it is more up to date. See if that fixes your issue.

1 Like

Any ideas why, everytime I reboot and log in back to Plasma, my latte-dock doesn’t load my default layout correctly?

I have to change the layout to something else and change it back to the Default one to get show up the correct layout.

See this post on how to set up Latte-dock auto-start the proper way.

Done all that and that works fine. Its just the problem that latte-dock doesn’t load the layout correctly. I have to change the layout from the menu and then change it back to mine.

Strange thing is that it doesn’t happen everytime.

Maybe you can see some ideas from the journal when this happens?

sudo journalctl -b -0 | less

and search for latte?