Latte Dock, settings window

Hello everybody!
Friends, after updating Latte Dock, a window with settings appears every time the system starts “cold” (screenshot). I can’t figure out what I should do to prevent it from appearing. I tried to remove and install Latte Dock again - no effect.
Tell me what to do?
Thanks

Have you looked into Autostart in your settings? Not on KDE so sorry for not being more specific.
Or into /etc/xdg/autostart?

I cannot say this with certainty but I was previously running the “Git” version of Latte-Dock prior to the 10.0 update and I was on Manjaro and I was experiencing the same problem with Latte-Dock on my KDE install so it can’t be just an EndeavourOS thing…

If I didn’t enable the “Autostart” option in Latte-Dock or add it to the KDE Autostart options myself this issue didn’t occur, BUT, it then wouldn’t launch when I logged into my KDE Session so it was equally useless as I had to manually launch it each time I wanted to use it which was ALL OF THE TIME.

I suspect this is one of three things;
1.) A bug with Arch-based distributions (The most likely reason)
2.) A bug with Latte-Dock & how it interacts with KDE/Arch
3.) A bug with the KDE Desktop Environment (The least likely reason)

I hope you find a solution, good luck.

@VlPo I also use Latte dock and I didn’t have that issue after updating. Perhaps it is the version you are using (git) as @TOGLK said. Over here the one in the community repo runs flawlessly.

What version is the Community Repo currently distributing?

(I’m new and don’t know where I’d look online in order to find this information, so any guidance in this regard would be appreciated)

I was using the “Git” version that was available prior to the full release of Version 10.0 just a few days ago.
If the OP using the “Git” version too then it could be that.
But… If the current community version of the package is only 9.0 then this could be an issue that effects all versions of the 10.0 release, both “Git” and “Regular” package versions. And, it is just a matter of time before the 10.0 Full Release is added to the Community Repositories…

But I’m speculating a lot here, and I don’t have all the details.

@pebcak @TOGLK @Bryanpwo thank you for answering!
I have this version of Latte Dock installed.

But I seem to have solved this issue, but I didn’t understand how it worked :face_with_raised_eyebrow:
In the system settings, I deleted the item with the launch of Latte Dock. I turned off the system. Launched it. The settings panel did not appear, although the Latte Dock itself has opened and is working. I turned off the system again. Launched it. And the settings window appeared again and the Latte Dock launch item appeared again in the system settings.
Now I have disabled the autorun option in the settings of the Latte Dock itself. Turned it off. I turned it on. The panel starts normally, the settings panel does not appear. There is no item for Latte Dock in the autorun system settings. I double-checked several times - everything works adequately.

3 Likes

From a running system:

yay -Ss latte-dock
aur/latte-dock-git r5484.9790b0cd-1 (+24 0.11) 
    Latte is a dock based on plasma frameworks that provides an elegant and intuitive experience for your tasks and plasmoids
community/latte-dock 0.10.0-1 (1.4 MiB 6.1 MiB) 
    A dock based on Plasma Frameworks

On www:

https://archlinux.org/packages/
https://aur.archlinux.org/

1 Like

Just to confirm some details,

Does it now operate as expected through multiple system reboots?

Does the “Latte-Dock Settings Window” still appear after rebooting your system?
Yes it does still appear, OR, No it does not appear anymore?

Thanks :slight_smile:

1 Like

Now I have deliberately turned off the system completely once again and then started it again.
Yes, the Latte Dock settings window no longer appears, and the Latte Dock itself works correctly.

P.S. I can make a video :slight_smile:

1 Like

No need for a video, but thanks for the offer.

I just wanted to make sure you had resolved the issue.

It seems like this is an issue with how Latte-Dock is assigning itself to the KDE Autostart Configuration Menu.

Whatever method is being used by the Latte-Dock developer quite clearly either isn’t stable, or, isn’t implemented correctly.

The added frustration is that Latte-Dock is designed in such a way that when you add it to the KDE Autostart Configuration Menu yourself manually and then open up the settings window for Latte-Dock it’ll see that you’ve added it manually and then update the in-app toggle automatically, which wouldn’t be an issue if it worked properly, but it doesn’t, and that is where the conflicts lay.

Maybe one of us here should reach out to the Latte-Dock developer and inform them of this bug if it hasn’t already been reported, because theirs clearly something broken with Latte-Dock and we can’t be the only people to have experienced this issue/bug.

I didn’t understand how it works either. Because the Latte Dock autorun is disabled in the system settings. Autorun is also disabled in the settings of the Latte Dock itself. But the panel starts successfully at system startup and works :slight_smile:

Strange,

Clearly a bug somewhere, if I was you I would report this to the developer of Latte-Dock so they can investigate this thoroughly to work out what is going wrong with it.

Hello I am the Latte dev.
I find the members of the thread to be pretty informative so you may be able to define exactly the bug if any. Lets say some of the facts for Latte v0.10

  1. In this version when Latte is already running and the user tries to launch it again then Settings window is shown, such behavior has the benefit that if the user removes all of its docks and panels then it can readd them from Settings window
  2. The users have reported plenty of times that launching Latte to early in startup process blocks many things so in the new latte desktop file a line was added to start a little later: InitialPreference=1

The thread topic means that Latte during startup is trying to autostart itself two times. So the user should first check in ~/.config/autostart folder that there arent two or more files trying to autostart Latte. If this requirement is met then it means that Plasma Desktop is identifying Latte as a normal application and is trying to autostart by restoring previous session (no idea how Latte can prevent that from happening). So If the user has enabled Plasma Restore previous session then he can safely remove all latte related desktop files from ~/.config/autostart .

No idea if this is considered a bug or an application requirement.

3 Likes

I don’t have a Latte Dock entry in this folder at all…

If you dont have any latte autostart record at all then Plasma restore session has double records for Latte and that makes it not a Latte bug then.

1 Like

you can try the following and activate afterwards latte from autostart records

1 Like

Most likely you are right.
If you look at the screenshots provided by me, there is no LatteDock autorun entry anywhere. But LatteDock successfully starts and works. If you exclude LatteDock in the session settings, the panel does not start anymore.
That is, there may be a duplicate startup command somewhere.
But where can I find it? :roll_eyes:

all sessions data are stored at folder: ~/config/sessions
which of the previous sessions should be restored are found in file: ~/.config/ksmserverrc

No, I never found a duplicate LatteDock startup command.
However, following your recommendations:

  • Add latte-dock to the exceptions on the session settings page to prevent LatteDock from “phantom” startup

  • And then add LatteDock autorun on the add applications page

Solves the problem that I have with the appearance of the LatteDock settings window at system startup.
Thank you! :handshake:

3 Likes