Latitude 5530 & SD Card Driver

Hi all,

I seem to be having an issue with the SD Card reader on this Latitude 5530. For some reason I cannot get any SD Cards to work with this reader. It works when using a USB C dock and I know the SD cards are not the issue since they work on my other systems. Here is some info on the device:

lspci -nn

0000:00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (16) I219-LM [8086:1a1e] (rev 01)
0000:71:00.0 SD Host controller [0805]: Genesys Logic, Inc GL9755 SD Host Controller [17a0:9755] (rev 01)
10000:e0:06.0 PCI bridge [0604]: Intel Corporation 12th Gen Core Processor PCI Express x4 Controller #0 [8086:464d] 

lspci -vv

0000:71:00.0 SD Host controller: Genesys Logic, Inc GL9755 SD Host Controller (rev 01) (prog-if 01)
        Subsystem: Genesys Logic, Inc GL9755 SD Host Controller
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 146
        IOMMU group: 16
        Region 0: Memory at 9fe00000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [80] Express (v2) Endpoint, MSI 00
                DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
                        ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset- SlotPowerLimit 10W
                DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
                        RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 256 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr+ TransPend-
                LnkCap: Port #85, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 unlimited
                        ClockPM+ Surprise- LLActRep- BwNot- ASPMOptComp+
                LnkCtl: ASPM L1 Enabled; RCB 64 bytes, Disabled- CommClk+
                        ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed 5GT/s, Width x1
                        TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
                DevCap2: Completion Timeout: Range ABCD, TimeoutDis+ NROPrPrP- LTR+
                         10BitTagComp- 10BitTagReq- OBFF Via message/WAKE#, ExtFmt- EETLPPrefix-
                         EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
                         FRS- TPHComp- ExtTPHComp-
                         AtomicOpsCap: 32bit- 64bit- 128bitCAS-
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR+ 10BitTagReq- OBFF Disabled,
                         AtomicOpsCtl: ReqEn-
                LnkCap2: Supported Link Speeds: 2.5-5GT/s, Crosslink- Retimer- 2Retimers- DRS-
                LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
                         Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                         Compliance Preset/De-emphasis: -6dB de-emphasis, 0dB preshoot
                LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete- EqualizationPhase1-
                         EqualizationPhase2- EqualizationPhase3- LinkEqualizationRequest-
                         Retimer- 2Retimers- CrosslinkRes: unsupported
        Capabilities: [e0] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000fee00578  Data: 0000
        Capabilities: [f8] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=375mA PME(D0-,D1+,D2+,D3hot+,D3cold+)
                Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=0 PME+
        Capabilities: [100 v1] Vendor Specific Information: ID=17a0 Rev=1 Len=008 <?>
        Capabilities: [108 v1] Latency Tolerance Reporting
                Max snoop latency: 3145728ns
                Max no snoop latency: 3145728ns
        Capabilities: [110 v1] L1 PM Substates
                L1SubCap: PCI-PM_L1.2+ PCI-PM_L1.1+ ASPM_L1.2+ ASPM_L1.1+ L1_PM_Substates+
                          PortCommonModeRestoreTime=255us PortTPowerOnTime=3100us
                L1SubCtl1: PCI-PM_L1.2+ PCI-PM_L1.1+ ASPM_L1.2+ ASPM_L1.1+
                           T_CommonMode=0us LTR1.2_Threshold=3375104ns
                L1SubCtl2: T_PwrOn=3100us
        Capabilities: [200 v1] Advanced Error Reporting
                UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
                UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
                CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout+ AdvNonFatalErr+
                CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- AdvNonFatalErr+
                AERCap: First Error Pointer: 00, ECRCGenCap+ ECRCGenEn- ECRCChkCap+ ECRCChkEn-
                        MultHdrRecCap- MultHdrRecEn- TLPPfxPres- HdrLogCap-
                HeaderLog: 04000001 0000000f 71070000 99cb3515
        Kernel driver in use: sdhci-pci
        Kernel modules: sdhci_pci

I’ve tried Ubuntu/Debian & Fedora but the issue remains persistent in all distros for some odd reason. At first I thought it was a driver issue but found they were merged since the 5.4 kernel. See: Genesys Logic, Inc GL9750 SD Host Controller not recognized

I’ve searched through other forums but wasn’t able to find someone else with this issue besides this one:

Has anyone else ran into this issue for the SD Card reader before? The workstation is fairly new.

hey welcome here @arrozmio :enos:

does it show anything with lsblk -f about the sd card plugged?
as your output shows a driver/module for it is used:

        Kernel driver in use: sdhci-pci
        Kernel modules: sdhci_pci

What i do to start debugging in these cases is to unplug the sd-card open a terminal and start live journal output:
journalctl -f
and after this plug in sd-card again to watch the output there … in many cases it will show something that hints on the underlaying issue.

Many Latitudes have an option to enable/disable the SD card readers from the UEFI/BIOS menu. Be sure to double-check yours has been enabled.

Hi Bluish,

Thanks for your reply! Yes, I went through the bios settings last night thinking that may be it but unfortunately no. The SD Card is enabled but the “Read-Only” option is disabled for it.


Hi Joe,

Thanks for the welcome! I ran journalctl -f and received the following:

I left the SD Card in the slot overnight and it was able to detect it being removed & reinserted. I am using balena etcher to write a pi image to an sd card. I also tried dd but was faced with the same issue. I keep seeing the same thing from journalctl regardless of system/method:

I/O error, dev mmcblk0
to me it looks like there is no error with drivers/firmware for the reader… it looks more like an issue with the sdcard or or hardware itself (hardware issue) a bad contact p.e. or loose cable…

Edit: What happens if you try to mount the card?

Try the following

rmmod sdhci_pci
rmmod sdhci
modprobe sdhci debug_quirks2="0x80000000"
modprobe sdhci_pci

Edit: You should make sure you back up your date in case.

1 Like

@joekamprad I feared that so I installed Windows on this machine and had no issues using balena to write to the SD Card

Driver was downloaded from here:

@ricklinux here is what happens when I run that command.

I can mount just not write but I’m afk so I will have to double check.

Found an Ubuntu page that shows support for it: Dell Latitude 5530 (Core i7-1265U). Tried booting into an image live usb of that distro to test but no luck in booting it.

What exactly do you mean by you can mount but not write on Linux?

How do you try writing to it?

Well I am using Balena Etcher to write armbian to an SDCard. I tried using dd too but get the same error regardless of the method when using any distro. It works in Windows just not in Linux for some odd reason. I’ve tried 3 different SD cards all different size and two different manufacturers. They all work on my Thinkpad with no issues. Just not on the 5530. Oddly enough, if I use a USB C hub that has Ethernet, usb ports, & Card reader (micro & regular) then it works no issues.

I’m not sure the issue exactly but seeing this in the log.

Sep 04 11:51:58 hachinosu AppImageLauncher[2368]: QStandardPaths: runtime directory '/run/user/1000' is not owned by UID 0, but a directory permissions 0700 owned by UID 1000 GID 1000

Appimage Launcher? Are you using an app image for etcher instead of installing etcher from the AUR?

Is the Dell laptop updated with the latest UEFI Bios?

Yes, I was using the appimage since that is what was showing on their website. I went ahead and downloaded the one from the AUR. Here is the journalctl -f output.

I ran fwpudmgr and it shows as no updates being found.

omar@hachinosu ~]$ sudo fwupdmgr get-updates
Firmware metadata has not been updated for 30 days and may not be up to date.
Update now? (Requires internet connection) [y|N]: y
Updating lvfs
Downloading…             [***************************************]
Successfully downloaded new metadata: 9 local devices supported
Devices with no available firmware updates: 
 • Integrated Webcam FHD
 • Internal SPI Controller
 • Internal SPI Controller
 • SSD 970 EVO Plus 2TB
 • UEFI Device Firmware
 • UEFI Device Firmware
Devices with the latest available firmware version:
 • Package level of Dell dock
 • RTS5413 in Dell dock
 • RTS5487 in Dell dock
 • VMM5331 in Dell dock
 • WD19S
 • BC901 NVMe SK hynix 512GB
 • System Firmware
 • UEFI dbx
 • Unifying Receiver
No updates available

What version is your Bios? I think it is A21 is the latest but i can’t tell without the serial number on the Dell site.

inxi -Faz | eos-sendlog

Post the url

Here is the link url from that command:

Ya it’s newer so what i looked up must be an older model. It shows v: 1.15.0 date: 07/11/2023

Did you try a different Etcher instead of the app image?

Edit: Actually i usually use etcher-bin

I noticed that the bios date seems to be off for some reason. Not sure if that may mean anything.

Here is the page for the latest one:

Here is the one my report showed:

I did install etcher-bin from the AUR and pasted the output here:

I think your fine on the Bios date. It’s the same version and sometimes the date won’t match exactly but the version does.

The error messaging seems very similar. Did you remove the app image version of etcher before installing the AUR version?