Latest upgrade breaks my Thunderbird

Guys, todays updat ebroke my Thunderbird, it won’t start.
In the terminal, I get this error:
XPCOMGlueLoad error for file /usr/lib/thunderbird/ cannot open shared object file: No such file or directory
Any ideas how to fix this?
I am using an older version of Thunderbird, not willing to upgrade it, as newer versions lack importan functionality for me (tray icon)

You may need to downgrade icu, If this does not break other things.

Downgrading icu unfortunately breaks a lot of things.

You tell us what the problem is: an OUTDATED version of Thunderbird. Sorry to be rude, but there is no tray icon extension Thunderbird 68.x besides this one:

Or migrate to another mail client.

Allright then: Any suggestions for an alternative qt5 mail client that supports pop3 and a tray icon/minimize to tray functionality besides the usability monster kmail??
I hate having my mail app open unminimised all the time, this is not acceptable for me.

Alternatively: Is there a way to have icu64 and icu 65 installed parallelly?

Well… A little google search - you could have done it by yourself - returns:

Trojita: last release back in 2016 and KMail. There is not a lot a QT based mail client.

If you want to stay with your OUTDATED and INSECURE version of Thunderbird, you can grab it here:

And install it in your userspace, create a link, and remove newer version using sudo pacman -R thunderbird

Note to other moderators: I want to apologize for being so rude in this thread. Won’t post here anymore. Good luck.

Trojita neither supports pop3 nor multiple accounts.
Thunderbird 60 is already installed, no need to install it again.
And yes, if there is no way to have an alternative mail client that suports everything I need, I will stay with an INSECURE and OUTDATED thunderbird.

I do not see anything related to icu65 there.

Container it :wink: or use snap…
Archlinux do not support partly updates…


F*ck. I hate containers and schnaps packages.
It’s one of these days I regret using linux, am struggling with kmail for about an hour now, it doesn’t even offer a spam filter.

Claws has a tray, :sweat_smile: or find flatpak snap whatever there is. Is pitty functions goes out. Dont know a proper mailer currently if new mailers come, it would be a webkit thing i think,the trend is in such thing

you didnt tried thunderbird-60-bin or even thunderbird-52-bin from aur?

Why do you need the tray icon? What is the purpose other than its quicker to get into Thunderbird? Just asking?

These will run only with everything in english. I prefer to have my applications in my native language.

The tray icon also gives me an accoustic and visual indication of new mails.

I can understand why you like it. Thunderbird does chime when you open it and it downloads the mail but until you open it you don’t know if there is mail.

Problem solved, someone created an ICU64 package and put it on the AUR:

Woo hoo! Lucky you! :smiley: