Latest kernel reboot/shutdown problem

Hello, I have a weird problem with the latest kernel (and the Zen too). I can’t shutdown nor reboot my OptiPlex 7040. Seem like the PC going to deep sleep but it isn’t wake up. Power led still on and the monitor going to standby mode. Only the force power off help.
I have no problem with the LTS kernel.
I’m sure its the latest kernels because same happened with OpenSuse TW, Fedora 39 beta, Manjaro too…
What would be the root cause of this incident? Thanks


What method do you use to shutdown/reboot your computer? Have you tried any other methods to see if they also cause your computer to not shutdown completely?

I have a similar problem with dell Optiplex 5040 mini tower (it has the same shape as yours). The problem started two weeks ago. Both with gnome and KDE. With yesterday’s update it looks like I can reboot, but shutdown is still not working.

Same here. Only the LTS one working flawless. Its a kernel problem because same happenes with me debian based and OS TW distros too.

It seems to be related to problems with shutting down or rebooting their OptiPlex 7040 computer when using the latest Linux kernel versions. Here are some possible root causes and troubleshooting steps for such an issue:

  1. Kernel Compatibility: As you mentioned, the problem started with the latest kernels. It’s possible that there’s a compatibility issue between the latest kernel versions and the hardware or drivers of the OptiPlex 7040.

    • Solution: Try downgrading the kernel to a previous version to see if the issue persists. This can be done using the package manager of the Linux distribution you are using.
  2. Driver Issues: Sometimes, kernel updates can lead to compatibility problems with specific hardware components or drivers.

    • Solution: Check if there are any proprietary drivers required for your hardware (e.g., graphics card, network adapter) and ensure they are up to date or compatible with the latest kernel.
  3. Power Management Settings: The issue of not waking up from deep sleep could be related to power management settings.

    • Solution: Check your system’s power management settings, including BIOS/UEFI settings and Linux power management settings. Make sure they are configured correctly and try adjusting them if necessary.
  4. BIOS/UEFI Update: Outdated BIOS/UEFI firmware can sometimes cause compatibility issues with the latest hardware and software.

    • Solution: Check if there is a BIOS/UEFI update available for your OptiPlex 7040 and apply it if necessary.
  5. Logs and Error Messages: Check system logs (e.g., /var/log/syslog, /var/log/dmesg) for any error messages or warnings that might provide clues about the issue.

  6. Kernel Parameters: Experiment with kernel parameters when booting to see if any combination helps resolve the issue. For example, you can try adding or modifying parameters like acpi=off, noapic, or nomodeset in the GRUB configuration.

  7. Community Support: Since the issue seems to have affected multiple Linux distributions, it might be a known issue or have been discussed in the communities of those distributions. Check your forums or bug trackers for related discussions and possible solutions.

  8. Hardware Testing: If all else fails, it’s a good idea to test your hardware components, especially memory and storage, for any issues that might be causing the problem.

Remember to back up your important data before making any significant changes to your system configuration.