Laptop’s sleep (suspend to ram) froze

At a fresh(ish; about a week old) install of EndeavourOS with Plasma, it happened now once or twice that when I put the laptop into suspend to ram (i.e. sleep) by closing the lid of the laptop, it did not actually fully go to sleep.

  • I can hear the fans going
  • the screen is blank
  • the power LED is on
  • the keyboard does not respond – cannot even trigger the CapsLock LED

Any idea how to figure out what went wrong? (I am writing this just after I hard rebooted from the last time this happened)

If it’s relevant, this is my inxi -Fxxxz output:

System:
  Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc Desktop: KDE Plasma v: 5.27.7 tk: Qt v: 5.15.10
    wm: kwin_x11 vt: 2 dm: SDDM Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: SLIMBOOK product: PROX-AMD5 v: Standard
    serial: <superuser required>
  Mobo: SLIMBOOK model: SLIMBOOK v: Standard serial: <superuser required>
    UEFI: American Megatrends LLC. v: N.1.06GRU07 date: 03/22/2023
Battery:
  ID-1: BAT0 charge: 33.2 Wh (71.1%) condition: 46.7/46.7 Wh (100.0%)
    volts: 11.6 min: 11.4 model: standard type: Li-ion serial: <filter>
    status: discharging
CPU:
  Info: 8-core model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64
    type: MT MCP smt: enabled arch: Zen 2 rev: 1 cache: L1: 512 KiB L2: 4 MiB
    L3: 8 MiB
  Speed (MHz): avg: 1692 high: 4337 min/max: 1400/4370 boost: enabled cores:
    1: 1922 2: 1397 3: 1643 4: 4337 5: 1397 6: 1627 7: 1929 8: 1636 9: 1397
    10: 1400 11: 1397 12: 1400 13: 1400 14: 1400 15: 1400 16: 1400
    bogomips: 57492
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: AMD Lucienne vendor: Tongfang Hongkong driver: amdgpu v: kernel
    arch: GCN-5 pcie: speed: 8 GT/s lanes: 16 ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 05:00.0 chip-ID: 1002:164c class-ID: 0300
    temp: 41.0 C
  Device-2: Chicony Integrated IR Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-3:2 chip-ID: 04f2:b71a class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.0
    compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x14d5 res: 1920x1080
    hz: 60 dpi: 158 size: 309x173mm (12.17x6.81") diag: 354mm (13.9") modes:
    max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 23.1.6-arch1.4 renderer: AMD Radeon Graphics
    (renoir LLVM 16.0.6 DRM 3.52 6.4.12-zen1-1-zen) direct-render: Yes
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Tongfang Hongkong
    driver: N/A pcie: speed: 8 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api
  Server-1: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Tongfang Hongkong driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie:
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 bus-ID: 1-4.4:4 chip-ID: 8087:0029 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: N/A
Drives:
  Local Storage: total: 953.87 GiB used: 44.54 GiB (4.7%)
  ID-1: /dev/nvme0n1 vendor: SanDisk model: SSDPR-PX500-01T-80-G2
    size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: EDFMF0.0 temp: 31.9 C scheme: GPT
Partition:
  ID-1: / size: 934.08 GiB used: 44.54 GiB (4.8%) fs: btrfs dev: /dev/dm-0
    mapped: luks-1a45a072-e9ed-4416-ac7e-04b69f11a9cc
  ID-2: /boot/efi size: 998 MiB used: 720 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 934.08 GiB used: 44.54 GiB (4.8%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-1a45a072-e9ed-4416-ac7e-04b69f11a9cc
  ID-4: /var/log size: 934.08 GiB used: 44.54 GiB (4.8%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-1a45a072-e9ed-4416-ac7e-04b69f11a9cc
Swap:
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/dm-1 mapped: luks-f9afd717-fdc8-4b81-8ada-6207724a9dec
Sensors:
  System Temperatures: cpu: 47.4 C mobo: N/A gpu: amdgpu temp: 41.0 C
  Fan Speeds (rpm): N/A
Info:
  Processes: 386 Uptime: 2h 37m wakeups: 7 Memory: total: 32 GiB note: est.
  available: 30.74 GiB used: 5.78 GiB (18.8%) Init: systemd v: 254
  default: graphical Compilers: gcc: 13.2.1 clang: 16.0.6 Packages: pm: pacman
  pkgs: 1608 Shell: fish v: 3.6.1 running-in: yakuake inxi: 3.3.29

It happened again. But this time:

  • screen is blank
  • power LED is on
  • CapsLock LED is blinking
  • keyboard does not respond

This person appears to have the same or a similar model of laptop and had the same problem:

https://slimbook.es/en/forum/question/8271

In their case, installing a BIOS update and changing a power management option in the BIOS settings resolved the issue.

https://slimbook.es/en/component/questions/question/8149

Hello again Pascal.

That’s correct, you have to download this .zip, there you will have to flash first the BIOS and then the EC, (there is a .txt with the detailed processing called “instructions.txt”, translated to English).

Once you have flashed the BIOS and the EC, you have to enter the BIOS on boot (pressing F2), then go to “Advanced>>S3 Moder standby support” and replace the default value to “S3 ENABLE”.

Boot back to normal and test standby again.

It should be solved, we are waiting for your comments.

1 Like

Thanks. I checked and I already have that BIOS version and setting.

I will try switching from Zen to mainline kernel and see if that helps (it happened again just now), while I wait for Slimbook support to answer.

KDE itself is a mess. I had the same issue. I ended up changing my DE to gnome which works for my desktop (sleep and resume).

You know it’s a KDE issue, or just assuming (and based on what)?