Laptop mouse pad issue

it seems plasma on msi laptop need a lot of adjustment to get it working good.

i pressed my physical button on laptop mouse pad (which is supposely on mouse pad, mousepad LED lite is indicating mousepad on), but plasma display mousepad off and mouse pad is not working.


now i pressed again mouse pad button (shld be off mousepad now… the LED indicator indicating mousepad is off) , but plasma displayed it is on… and my mouse pad is still not working

Hardware buttons on laptops can sometimes be a hit and miss when it comes to functionality.

I’d suggest that you poke around here in the Plasma settings instead:

3 Likes

Do you have a separate mouse plugged in? Does the touchpad work when the separate mouse is unplugged?

There is a setting to disable the touchpad when a separate mouse is plugged in … I can’t find it just now, but report back here the answers to the above questions and I’ll keep looking.

i think plasma is a bit buggy in term: it keeps changing… flip flop… my mouse pad was having the problem in my first post… after i suspend the laptop and went for a nap, it is now ok again. my mouse pad works as normal, and the physical mouse pad button on/ off works exactly as it supposed to.

now my mouse pad is working as intended… so… how ? to fix or not to fix ? will the same issue appears next time randomly ?

note: i do have usb mouse connected all the time, it is still connected… but mousepad is back to normal itself already. so… i do’nt know should i just leave it as it is now and hoping it will not messes up again… or continue to dig to find the root of the problem ?

i can’t find the place you posted in photo… any idea what does that call in english ?

thx

It’s the first option below “Hardware”, (probably Input Devices in English) and then Touch Pad.

The Swedish translation from English is a thing of it’s own, as KDE went out of their way not using the English term that everyone in Sweden uses. For instance, Touch Pad translates as “Tryckplatta”, witch is correct i guess, but no one uses that word. The literal translation of “Tryckplatta” is “Pressure Plate”… erh!?

Sorry for the OT, but needles to say, it makes helping out a bit hard sometimes. :wink:

3 Likes

It is ok now, the touch pad icon appears on system setting all by itself. It is working fine now. Thank you.

1 Like