Laptop keyboard not working, cant get past sddm

The problem I am facing is that when i try to login into my system, on the sddm login page i can use my trackpad and even touch display, but nothing happens when i type on my keyboard, also i cant access tty. This happened after a update and a reboot after i fixed a grub issue. Keyboard does work when i boot up windows and in an live environment and when arch-chroot-ed in my machine. I have tried downgrading libinput and sddm, but that didn’t work, also tried reinstalling linux-firmware, libinput and xf86-input-libinput and also nothing. Journalct shows no entries. I am using arcolinux with kde plasma and sddm. Also I am using plasma in wayland but I am not sure if sddm on boot is xorg or wayland I haven’t touched that so whatever it is by deafult its using that. What can i do about this? Posting this here because i cannot find similar issue to mine on google.

Can you describe what specifically you did during the Grub maintenance?

Check if you have encountered a kernel bug by downgrading the kernel, or switching from mainline to the LTS kernel (or vice-versa) to test a different kernel version.

Hi. If you have an option to boot a fallback initramfs from grub, it is worth to try it. Maybe there is some problem with keyboard driver in early userspace.

I have tried that but the issue persisted there.

I didnt turn on my computer for a while so I was fixing the grub error that affected a lot of people a month ago, I chrooted into my shystem and ran grub-install -efi-directory=boot/efi/ . Will switch to an lts kernel and get back to you. But yeah i you know any other common problems that could affect me be it with libinput or xorg meantion them.

Maybe you can try to boot into tty by editing kernel parameters from grub and adding

Welcome to the forum @Kukinator.
Which kernel are in use on your machine?
Take a look here, i suggest you to try ltskernel

1 Like

I am running 6.1.7.-arch1-1, but i will still try to seitch to an lts one and get back to you. Thank you for the suggestion!

Hey, used chroot to add the lts kernel and voila it works, ill so i guess even earlier versions of the standard kernel can have issues with the internal keyboard. Thank you for the help and sorry for not trying that earlier.


Glad you got it worked!

Glad your issue got resolved @Kukinator!

Please consider marking “Solution”, the post which actually pointed out the solution.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.