Laptop is freezing after suspend

When I close the lid and open it after some time, laptop is freezing. It doesn’t respond even to ctrl+alt+reisub. I need to hold power button to reboot.

This problem is new after some recent updates. I’ve tried downgrading kernel to LTS but without success. I’m using KDE Plasma & Wayland without any proprietary drivers.

Somehow when I run systemctl suspend - it works properly.

Anyone knows where to start searching for a source of this issue?

So suspend with closing the lid did work before without problems?

Can you verify that also systemctl hibernate is working properly? (If you configured hibernation.)

Can you switch to another console with CTRL + ALT + F1 just to be sure the system is really dead.

CTRL + ALT + F2 should get you to a login prompt and CTRL + ALT + F7 back to your desktop.

Suspend & Hibernate did work previously.
ctrl+alt doesn’t work, as I said it’s complete freeze, I can’t even reboot with “ctlr alt prtscrn reisub” key combination
systemctl hibernate doesn’t turn off computer, so it can be source of problem.

It should be alt+print screen+reisub

I don’t suppose you’re using an nvidia graphics card are you? I had a similar problem recently, which I discovered was caused by nvidia-suspend.service and (optionally) nvidia-hibernate.service not being enabled.

I don’t use nvidia.

I’ve tried changing sleep.conf

But with no luck, sometimes it’s shutting down, sometimes it’s not. Now I’m trying adding pci=nommconf to kernel config because I use LG Gram laptop.

Also after wake up there is a black screen and I can only long press power, to power off.