Language shortcut not working?

Hi everyone, I have Endeavour Os (xfce) installed on a secondary laptop and i switch languages often. The left shift left alt thing worked fine for a for a few months but now doesn’t change the language anymore. I tried changing the shortcut to change layout option and i tried switching it to default and back neither fixed the issue, thank you.

Check this out @TowJo

Add Keyboard Layouts to panel to monitor toggle.