Konqueror fails to launch

Hello, this is not my language, I try not to be awkward,

I am still exploring Kde, I installed Konqueror to try it as both file manager and web browser, so I set it as default.

when I click on folders or shortcuts, it launches fine as file manager, no issue that I can see; but when in Thunderbird, QuiteRss, etc, I click on a link, to open in external web browser, it gets stuck with that animation, when the Konqueror icon is next to the mouse pointer ‘bouncing’, It is also showing in the taskbar, but it never opens. I also installed Falkon, for comparison, because it’s QT, and that launches fine.

I can click on Konqueror’s icons/shortcuts and start browsing just fine, it only gets jammed when it is ‘called’ by other programs, I installed it using

pacman -S konqueror

maybe I missed aditional packages that need to be installed as well?

Cheers.

1 Like

Please try the following:

Go to “System Settings > Personalization > Applications > Default Applications”
Select “Web Browser” and then “Konqueror”

I hope that will do it :slightly_smiling_face:

for reference:

1 Like

That it what I meant to explain, Konqueror is already installed, and set as default web browser / file manager, but when programs call it to launch, it fails to launch.

If I launch it myself, no problem, only when programs call it fails.

Laters.

You may also have a look at the file associations:

“Konqueror” should be in the first place

1 Like

Ok, I did, still it gets stuck at launch,

Its fine, I will use something else.

Ok, so I have an older laptop, I installed fedora 32, on Plasma 5.18.3, and also fails to launch konqueror if set as default.

Then I instaled gecko linux, on Plasma 5.19.3, and it does launch konqueror when set as default, no problem.

So I guess it is a plasma bug and not a distro bug. I might create an account on KDE forums, jus to find out. xD

Laters.

I am going to try it when I get home. What are you using where it doesn’t launch it?

It fails when a program, mainly thunderbird, Quiterss, tries to open konqueror, like clicking on a link inside a email, i.e. when you have to confirm a new account on some website, that link is supposed to lauch whatever browser is default, If default is set to konqueror, then konqueror gets jammed at launch. Not the program that made the ‘call’.

It is not a big deal, I use web browsers indistinctively (is that the word?), it is just weird that it fails to launch korqueror, since it is made for Kde.

Laters.

Edit: I just got an idea, I’m gonna install EOS on the other laptop, with xfce, and set konqueror as default, and see what happens.

Anoher edit:

Ok, so, try to do what I did; I installed a distro, on kde, and opened

System Settings > system information > click on the ‘https://endeavouros.com’ link

if you set konqueror as default, you can see the bouncing icon next to the pointer, and you can see the konqueror tab on the task manager, but it gets jammed.

I tried it in vbox with a plasma install and it works fine.

Bloody hell, it is just me then,

Ok, tnx.

Check the settings in konqueror under performance keep one instance open?

Edit: I didn’t see any difference changing this setting anyway. But i did try another install on vbox and Konqueror does work on EndeavourOS KDE Plasma.

Yeah, I did, I probably made a bad EOS install; it’s all right, next time I break my system I’ll try again, it is not going to be that long xD.

Laters.

1 Like

You do not need to know why, just that I made a fresh install of EOS, :sweat_smile:

But, this time, because of Intervention of Mighty Quetzalcoatl (mexican slang for “I-don’t-know-what-the-hell-happened” :hocho: :heart:), konqueror seems to be working fine.

All right, the last time I did a live install, I chose to remove, or ‘not to include’ a few packages that I know I do not need or not want, like Kde connect, teatime, you know, bloat.

but this time, I just let it go with standard install, and konqueror works.

So I quess I will try removing one program at a time untill I nail the one that breaks konqueror if it is missing.

Laters.

That might work… I run plasma with the EndeavourOS install and then I just add multimedia packages such as vlc, rythmbox, lollypop, celluloid, libreoffice, gimp, gparted, korganizer, pamac the dependency for discover. That’s about it really. Sometimes chromium.