Kodi problem after update today

After todays update , kodi problem began . Kodi starts fine but when trying start a show from any addon , kodi shuts down . I uninstalled and re-installed but problem continues .
When I start kodi from terminal this is the message it shows after it shuts down
( /usr/bin/kodi: line 186: 115582 Segmentation fault (core dumped) ${KODI_BINARY} $SAVED_ARGS ) . Anyone else having same issue ?

1 Like

I suggest you first check upstream kodi forum for similar bug reports.

Not sure how that would help as all was fine before update this morning . Is there something specific there I should be looking for ? I did a quick look through the kodi community forum with no insight to anything simular . Both packages ( kodi and kodi-addon-inputstream-adaptive ) are from the Endeavour community repo . Also 2 Aur packages ( iptv-simple and kodi-addon-inputstream-ffmpegdirect ) .
I will continue trying to troubleshoot to find out were and what is causing problem . Kodi was not a upgraded package this morning .
Hopefully I’m not the only one experiencing this problem after upgrading . That would be strange !
Wish I could remember the packages that were upgraded with hope of downgrading package that caused issue .
Still looking for solution … Thanks for the advice though …

That’s not enough with suspected bugs. If nobody experiencing this bug posts a bug report, nobody will know. So, go ahead and report it and most probably you will get the best advice. Many of those users are using Arch AFAIK.

Everything is logged in /var/log/pacman.log.

pahis stands for pacman history. You may have to install it.

sudo pacman -S pahis

Then enter “pahis” in a terminal window.

Pudge

2 Likes

Thank you Petsam for this info ( Everything is logged in /var/log/pacman.log. ) . As for the rest , I use 3rd party addons . Just talked with fellow Endeavour friend and after just doing his updates , He know has same issues as me . Yes He’s now upset with me . He only has some live-tv that still works but rest close when trying to use .
Hopefully fix will come soon as others start to encounter same problem . Still waiting for fix ! not resolved and broke cause of latest update !

Thanks Pudge for that info.
Now that I know others will encounter the same issue . hopefully next set of updates will resolve this problem . Or if someone finds solution before and posts it here . At this point I’m frustrated , been hours trying to fix with no success . Most of the time I would just do a fresh install , but now I know that would not fix . Waiting game . Waiting for some one with the skills to resolve .

Welcome to the joys of using unofficial 3rd party add-ons with Kodi. You will not get support for them on the Kodi forum. They do not have time or desire to support them. You will have to wait for the author of said add-on to do the fix. This is why I personally stay with the add-ons available in their official repository.

Yes I’m fully aware . Just so everyone is aware too that no addons were updated in kodi . just system updates borked it . Even kodi offical i tried even don’t work . So broke more than just 3rd party addons . Yes after testing many , I have enough working till fix is in . Updates should not break it !
Not my first rodeo , Reporting latest update is to make aware to others what could happen when they update . Informing all that update broke kodi so issue can be resolved to what caused the problem . Maybe from here or addon developers themselves . Either way the community is now aware !
Can’t fix anything if no one reports it ! Let’s find a solution !

Anybody discover which package update is the cause ? Will check back in the morning .
Good night everyone …

I had some problems with kodi crashing some time ago, I had to delete a couple of lines in a python file.
It is working now and Iĺl update now and see if kodi still works.
These are the updates:

atk-2.38.0-1 inxi-3.3.14.1-1 iproute2-5.17.0-1 ncdu-2.1-3 nodejs-17.8.0-1
perl-libwww-6.59-1 python-pyparsing-3.0.7-1 strawberry-1.0.3-1

fingers crossed.

Edit: Yes, it crashes…

I downgrades a few packages, but didn’t find the problematic one yet.

These a the last 3 lines from my kodi log.

2022-03-25 10:35:09.482 T:7957 INFO : CPythonInvoker(25, /home/citroen/.kodi/addons/plugin.video.seren/seren.py): script successfully run
2022-03-25 10:35:09.512 T:7957 INFO : Python interpreter stopped
2022-03-25 10:35:23.698 T:7958 INFO : initializing python engine.

Looks like a python thing again.

I updated everything again and removed Seren.
Now it seems to work again.
I ran a movie for a couple of minutes and no crashes, until I stopped the video, then the screen froze, but he did that before.

1 Like

Good morning everyone . Good morning Lemon ! Thank You very much Lemon for the great info you provided .
With the info Lemon provided led me to try downgrading the Python package .
SUCCESS ! All working again !

Did you downgrade python-pyparsing-3.0.7-1?
I did that but this didn’t help on my side. :face_with_raised_eyebrow:

Hi Lemon , first thing this morning I did updates . Tried , but diden’t solve issue . Then I read your posts and downgraded Python by 1 with no success . Downgraded down i more and all now working . Worked for friend I borked yesterday too . All happy and good at are end . System seems fine too nothing else broken that I can find .

1 Like

Trying to find package . Don’t know command to find wich one I’m using . I believe though that the package is ( python 3.10.2 ) Will watch to see your results .
Anyone know command to verify witch package I’m using ?

Try this:

pacman -Qi python

1 Like

Just confirmed at my end .
I did updates and core python was updated , broke kodi .
I ( sudo downgrade python ) chosse ( python 3.10.2 ) .
Tried kodi and no result , rebooted computer , kodi working again .

Thanks Lemon ran that command ( pacman -Qi python ) Result ( python 3.10.2-1 )

Did it work for you ? Results ?