Kodi broken with todays update

Same here, Nvidia/X11. It’s most likely because of the updated ffmpeg package to version 5.0.
You could try to install the ffmpeg4.4 package and see if it works or install the flatpak version of kodi.
Keep in mind, if you install the flatpak version, you have to copy or link the content of the ~/.kodi folder to the ~/.var/app/tv.kodi.Kodi/data folder if you want to keep your settings.

Kodi is still working but I havent updated today.
These are my updates waiting:

accountsservice-22.07.4-1 aom-3.3.0-1 btrfs-progs-5.16.2-1 ffmpeg-2:5.0-4
ffmpegthumbnailer-2.2.2-4 firefox-97.0.1-1 firefox-i18n-nl-97.0.1-1
librsvg-2:2.52.6-1 libwnck3-40.1-1 linux-5.16.10.arch1-1
linux-headers-5.16.10.arch1-1 vmaf-2.3.0-1 waylandpp-0.2.9-1 webkit2gtk-2.34.6-1

AMD kernel driver and x11. This is most probably a ffmpeg 5 problem.

1 Like

I updated and Kodi fails, same error.
AMD on x11, no Nvidia.

I downgraded ffmpeg and ffmpegthumbnailer, but didn’t help, still no Kodi.

Do you have ffmpeg4.4 installed?

Check with:

pacman -Q ffmpeg4.4

If not, try to install it:

sudo pacman -S ffmpeg4.4

ffmpeg got a major version upgrade, ffmpeg4.4 is a legacy package that can (and should) be installed alongside ffmpeg.

Installed on my system, but I’m experiencing the same problem.

yay -Qs ffmpeg
local/ffmpeg 2:5.0-4
    Complete solution to record, convert and stream audio and video
local/ffmpeg4.4 4.4.1-3
    Complete solution to record, convert and stream audio and video

That’s a pity.

Then just wait until it gets updated. Should be soon enough, I would think…

1 Like

Same problem here.

That might be the package at fault; someone could confirm with a downgrade?


Yes, this is the one, I downgraded and Kodi is running again.

1 Like

Yes, that’s the one.

downgrading package waylandpp (0.2.9-1 => 0.2.8-1)

That worked.

1 Like

Looks like Kodi needs a rebuild against this newer library (or the library package doesn’t like LTO). Has a bug been filed already?

I saw this - https://bugs.archlinux.org/task/73854?project=5&string=kodi

1 Like

OK, report is filed, it’s just a matter of waiting for it to be fixed.

1 Like

Did you downgrade from the pacman cache, or is there a statement that can do it from the repos? Because my version from the cache won’t install:

[dromundkaas@Pure log]$ yay -U file:///var/cache/pacman/pkg/waylandpp-0.2.8-1-x86_64.pkg.tar.zst 
Pakete werden geladen …
Fehler: '/var/cache/pacman/pkg/waylandpp-0.2.8-1-x86_64.pkg.tar.zst': Erforderliche Signatur für Paket fehlt
 -> exit status 1

Don’t use pacman -U or yay -U.
Use sudo downgrade waylandpp. It will fetch the version from remote sources.

kodi is also existing in testing since today:

chances are that the problems are fixed once it hits stable.

1 Like

I just tried it. It indeed seems to solve the issue. Should hit stable soon.

Any particular reason for this? I haven’t downgraded that often, but usually I keep at least 3 versions in cache. This sounds helpful if you don’t have an older version in cache.

@DromundKaas this worked for me -

sudo pacman -U /var/cache/pacman/pkg/waylandpp-0.2.8-1-x86_64.pkg.tar.zst

1 Like

This was his problem. Missing signature key.

I normally use downgrade. The only case I install directly from cache is, when there is no remote package available. In my opinion it’s faster.