Kodi broken with todays update

After an update this morning, Kodi is now broken for me. I use it most days, and it worked yesterday. The following message appears when starting from a shell:

/usr/lib/kodi/kodi.bin: symbol lookup error: /usr/lib/kodi/kodi.bin: undefined symbol: _ZN7wayland9display_t15roundtrip_queueERKNS_13event_queue_tE

Kodi was not updated today. The following packages however were updated today for me:

[2022-02-18T07:44:20+0100] [ALPM] upgraded e2fsprogs (1.46.5-2 -> 1.46.5-3)
[2022-02-18T07:44:20+0100] [ALPM] upgraded accountsservice (22.04.62-2 -> 22.07.4-1)
[2022-02-18T07:44:20+0100] [ALPM] upgraded alsa-card-profiles (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-18T07:44:21+0100] [ALPM] upgraded alsa-plugins (1:1.2.6-2 -> 1:1.2.6-3)
[2022-02-18T07:44:21+0100] [ALPM] upgraded aom (3.2.0-1 -> 3.3.0-1)
[2022-02-18T07:44:21+0100] [ALPM] upgraded btrfs-progs (5.16.1-1 -> 5.16.2-1)
[2022-02-18T07:44:21+0100] [ALPM] upgraded librsvg (2:2.52.5-1 -> 2:2.52.6-1)
[2022-02-18T07:44:21+0100] [ALPM] upgraded x264 (3:0.163.r3060.5db6aa6-1 -> 3:0.164.r3081.19856cc-1)
[2022-02-18T07:44:21+0100] [ALPM] upgraded vmaf (1.5.3-1 -> 2.3.0-1)
[2022-02-18T07:44:21+0100] [ALPM] upgraded ffmpeg (2:4.4.1-1 -> 2:5.0-4)
[2022-02-18T07:44:21+0100] [ALPM] upgraded chromaprint (1.5.1-1 -> 1.5.1-2)
[2022-02-18T07:44:21+0100] [ALPM] upgraded electron (16.0.8-1 -> 16.0.8-2)
[2022-02-18T07:44:22+0100] [ALPM] upgraded electron13 (13.6.8-2 -> 13.6.8-3)
[2022-02-18T07:44:22+0100] [ALPM] upgraded gstreamer (1.20.0-1 -> 1.20.0-2)
[2022-02-18T07:44:22+0100] [ALPM] upgraded gst-plugins-base-libs (1.20.0-1 -> 1.20.0-2)
[2022-02-18T07:44:22+0100] [ALPM] upgraded webkit2gtk (2.34.5-1 -> 2.34.6-1)
[2022-02-18T07:44:22+0100] [ALPM] upgraded eos-bash-shared (1.10.30-1 -> 1.10.31-1)
[2022-02-18T07:44:22+0100] [ALPM] upgraded ffmpegthumbnailer (2.2.2-2 -> 2.2.2-4)
[2022-02-18T07:44:22+0100] [ALPM] upgraded firefox (97.0-1 -> 97.0.1-1)
[2022-02-18T07:44:22+0100] [ALPM] upgraded gegl (0.4.34-1 -> 0.4.34-2)
[2022-02-18T07:44:22+0100] [ALPM] upgraded gst-libav (1.20.0-1 -> 1.20.0-2)
[2022-02-18T07:44:22+0100] [ALPM] upgraded pipewire (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-18T07:44:22+0100] [ALPM] upgraded gst-plugin-pipewire (1:0.3.45-1 -> 1:0.3.46-1)
[2022-02-18T07:44:22+0100] [ALPM] upgraded gst-plugins-bad-libs (1.20.0-1 -> 1.20.0-2)
[2022-02-18T07:44:22+0100] [ALPM] upgraded libde265 (1.0.8-1 -> 1.0.8-2)
[2022-02-18T07:44:22+0100] [ALPM] upgraded openal (1.21.1-2 -> 1.21.1-3)
[2022-02-18T07:44:22+0100] [ALPM] upgraded gst-plugins-bad (1.20.0-1 -> 1.20.0-2)
[2022-02-18T07:44:22+0100] [ALPM] upgraded gst-plugins-base (1.20.0-1 -> 1.20.0-2)
[2022-02-18T07:44:23+0100] [ALPM] upgraded gst-plugins-good (1.20.0-1 -> 1.20.0-2)
[2022-02-18T07:44:23+0100] [ALPM] upgraded gst-plugins-ugly (1.20.0-1 -> 1.20.0-2)
[2022-02-18T07:44:23+0100] [ALPM] upgraded java11-openjfx (11.0.14.u2-1 -> 11.0.15.u0-1)
[2022-02-18T07:44:23+0100] [ALPM] upgraded qt5-base (5.15.2+kde+r298-1 -> 5.15.2+kde+r300-1)
[2022-02-18T07:44:23+0100] [ALPM] upgraded kfilemetadata (5.91.0-1 -> 5.91.0-2)
[2022-02-18T07:44:23+0100] [ALPM] upgraded libwnck3 (40.0-1 -> 40.1-1)
[2022-02-18T07:44:24+0100] [ALPM] upgraded linux (5.16.9.arch1-1 -> 5.16.10.arch1-1)
[2022-02-18T07:44:25+0100] [ALPM] upgraded linux-headers (5.16.9.arch1-1 -> 5.16.10.arch1-1)
[2022-02-18T07:44:25+0100] [ALPM] upgraded nvidia (510.54-1 -> 510.54-2)
[2022-02-18T07:44:25+0100] [ALPM] upgraded qt5-speech (5.15.2-2 -> 5.15.2+kde+r3-1)
[2022-02-18T07:44:25+0100] [ALPM] upgraded qt5-webengine (5.15.8-7 -> 5.15.8-8)
[2022-02-18T07:44:25+0100] [ALPM] upgraded r8168 (8.049.02-57 -> 8.049.02-58)
[2022-02-18T07:44:25+0100] [ALPM] upgraded vlc (3.0.16-7 -> 3.0.16-8)
[2022-02-18T07:44:25+0100] [ALPM] upgraded waylandpp (0.2.8-1 -> 0.2.9-1)

Googling the error message doesn’t yield results, as the garbled nature of the missing function isn’t suited for search engines.

I am not running Wayland, but X11 (NVidia user sadly), so there might be some problem with an overeager installation in a package used by kodi, but that’s speculation on my part.

Does Kodi work for all of you?

Same error here.

NVidia or AMD for you? And X11 or Wayland?

Same here, Nvidia/X11. It’s most likely because of the updated ffmpeg package to version 5.0.
You could try to install the ffmpeg4.4 package and see if it works or install the flatpak version of kodi.
Keep in mind, if you install the flatpak version, you have to copy or link the content of the ~/.kodi folder to the ~/.var/app/tv.kodi.Kodi/data folder if you want to keep your settings.

Kodi is still working but I havent updated today.
These are my updates waiting:

accountsservice-22.07.4-1 aom-3.3.0-1 btrfs-progs-5.16.2-1 ffmpeg-2:5.0-4
ffmpegthumbnailer-2.2.2-4 firefox-97.0.1-1 firefox-i18n-nl-97.0.1-1
librsvg-2:2.52.6-1 libwnck3-40.1-1 linux-5.16.10.arch1-1
linux-headers-5.16.10.arch1-1 vmaf-2.3.0-1 waylandpp-0.2.9-1 webkit2gtk-2.34.6-1

AMD kernel driver and x11. This is most probably a ffmpeg 5 problem.

1 Like

I updated and Kodi fails, same error.
AMD on x11, no Nvidia.

I downgraded ffmpeg and ffmpegthumbnailer, but didn’t help, still no Kodi.

Do you have ffmpeg4.4 installed?

Check with:

pacman -Q ffmpeg4.4

If not, try to install it:

sudo pacman -S ffmpeg4.4

ffmpeg got a major version upgrade, ffmpeg4.4 is a legacy package that can (and should) be installed alongside ffmpeg.

Installed on my system, but I’m experiencing the same problem.

yay -Qs ffmpeg
local/ffmpeg 2:5.0-4
    Complete solution to record, convert and stream audio and video
local/ffmpeg4.4 4.4.1-3
    Complete solution to record, convert and stream audio and video

That’s a pity.

Then just wait until it gets updated. Should be soon enough, I would think…

1 Like

Same problem here.

That might be the package at fault; someone could confirm with a downgrade?


Yes, this is the one, I downgraded and Kodi is running again.

1 Like

Yes, that’s the one.

downgrading package waylandpp (0.2.9-1 => 0.2.8-1)

That worked.

1 Like

Looks like Kodi needs a rebuild against this newer library (or the library package doesn’t like LTO). Has a bug been filed already?

I saw this - https://bugs.archlinux.org/task/73854?project=5&string=kodi

1 Like

OK, report is filed, it’s just a matter of waiting for it to be fixed.

1 Like

Did you downgrade from the pacman cache, or is there a statement that can do it from the repos? Because my version from the cache won’t install:

[dromundkaas@Pure log]$ yay -U file:///var/cache/pacman/pkg/waylandpp-0.2.8-1-x86_64.pkg.tar.zst 
Pakete werden geladen …
Fehler: '/var/cache/pacman/pkg/waylandpp-0.2.8-1-x86_64.pkg.tar.zst': Erforderliche Signatur fĂĽr Paket fehlt
 -> exit status 1

Don’t use pacman -U or yay -U.
Use sudo downgrade waylandpp. It will fetch the version from remote sources.

kodi is also existing in testing since today:

chances are that the problems are fixed once it hits stable.

1 Like