KGpg assistant loads on start up of Kde Plasma

How does one stop KGpg assistant from loading every time desktop starts or boots up. Not using it for anything at the moment . Guess it’s part of Kde install?

Uninstall it. I don’t have it installed.

1 Like

It’s part of a meta package. So how can i remove it without it taking everything else?

sudo pacman -R kgpg

Should do it and not affect the meta pakage.

Okay i will try it. I thought it would grab everything and cause me issues. :wink:


[ricklinux@eos-kde ~]$ sudo pacman -R kgpg
[sudo] password for ricklinux: 
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing kgpg breaks dependency 'kgpg' required by kde-utilities-meta
[ricklinux@eos-kde ~]$ 

Weird. OK look in ~/.config/autostart and /etc/xdg/autostart for a desktop file and rename it to .desktop-old.

It is /etc/xdg/autostart and it is called org.kde.kgpg.desktop rename to:

sudo mv /etc/xdg/autostart/org.kde.kgpg.desktop  /etc/xdg/autostart/org.kde.kgpg.desktop-old

What is this going to accomplish? I haven’t removed anything yet.
Edit: Is it not possible to remove a package from a meta-package with pacman commands?

It will stop it loading at boot, as it will not uninstall without removing other stuff.

Answer - yes - sudo pacman -Rdd kgpg


From the man pacman

-d, --nodeps

Skips dependency version checks. Package names are still checked. Normally, pacman will always check a package’s dependency fields to ensure that all dependencies are installed and there are no package conflicts in the system. Specify this option twice to skip all dependency checks.

Specifically the last line:
Specify this option twice to skip all dependency checks.

pacman -Rdd packagename

WILL remove packagename and only packagename, no questions asked, no cautions offered.
Use with caution.


1 Like

Thanks for the explanation. I was looking at man pacman as i wasn’t 100% sure.

1 Like