Keyboard & Wifi sometimes don't work after boot

Hi guys,

I’ve a new computer where I installed EndeavouOS. Since the beginning, sometimes my keyboard and sometimes my WIFI don’t work.

WIFI:

  • Is directly coming from my Motherboard: gigabyte b650 aorus elite ax
  • Doesn’t work like 10 % of the times after a boot
  • When it doesn’t work (doesn’t find any networks), so far a reboot always made it work, it was never two times in a row

Keyboard:

  • Sharkoon Skiller Mech
  • Doesn’t work like 50 % of the times after a boot
  • It also happens that it’s twice or more in a row
  • Keyboard doesn’t work even before OS booted (so I can’t enter the bios)

I had a period of like one week where I didn’t have problem at all, in other weeks it happens several times.
It never seem to happen after my computer was in sleep, only after a boot / reboot.
I also just updated the bios and faced the keyboard problem again.
Endeavour is the only OS installed.

Here are some logs from the command: sudo journalctl -b -1 | curl -F 'file=@-' 0x0.st.
For the logged boot WIFI worked, but the keyboard didn’t. I’ll update with logs from the wifi problem once I encounter it again.

Do you have any idea what could be going on?
What do you need from me that could help troubleshooting this?

Thank you in advance for your help.

Here are the logs of Wifi not working:

Hi @schoko, welcome to the community. :slightly_smiling_face:

The keyboard is wired, is that right? When you boot and the keyboard doesn’t work, if you unplug the keyboard and plug it into a different USB port does it work? If so, my next question would be if the not-working port works for another device–for example, if you plug in a USB stick to the not-working port, is it recognized?

Check to make certain your PSU is up to the task. Sometimes if attached devices do not get enough power at boot they will get disabled as a port protection mechanism.

Thank you for your reply.

Yes, mouse and keyboard are wired.
When the keyboard doesn’t work, I can unplug and plug it in anywhere, even the same port and it will work every time.
I used my monitor’s KVM (M28U), I now switched to connecting the keyboard directly to the computer and so far I had no issues. But I remember that I did it in the past as well and had problems there too.
If it comes up again, I’ll post an update.

PSU should be fine, it has 850W for a 7800x3d and a 7900XTX.

Gotcha. Your case reminded me of something else, but sounds like it is not the same thing.

Are you able to use the keyboard in the BIOS when it is plugged directly to the computer this way?

The WiFi thing could be driver related. Have you tried the LTS kernel?

Are you able to use the keyboard in the BIOS when it is plugged directly to the computer this way?

The Keyboard is not available since the moment I press on the power button on my computer, so I can’t even enter the BIOS. If I’m fast enough with unplugging and plugging it in, I can use it in the Bios, yes.

I now switched to the LTS kernel. If I encounter the problems again or if I can use my computer for a week or so without problems I’ll post an update here. :slight_smile:

I used to have problems on arch linux in the past when using the stock kernels where my wifi would stop working, or exhibit strange behavior, or my keyboard or mouse would behave strangely.

Then I started building my own custom kernels, and I never had these problems again.

I’ve had these kinds of problems with manjaro, garuda and endeavour in the past, and what’s nice about endeavour is that installing a custom kernel is very easy here, unlike many other distributions.