Keyboard typing problem

On one of the machines here running EOS plasma, the keyboard has all of a sudden stopped typing into applications, eg Firefox, LOWriter.
Of note:

  • SDDM is the DM and it types fine in the login password there.

  • The machine is by default on X11. Both X11 and Wayland have same problem.

  • I did check the keyboard (Microsoft Curve 2000 USB) on another machine, no problem. Tried another keyboard on the problem machine, same problem.

  • journalctl -xb gave me nothing useful, other than it registers the keyboard

  • CTRL+ALT+F2 takes it to terminal login. CTRL ESC brings up system monitor, WINLOGO brings up main menu, multimedia keys function as expected

  • Keyboard is set in KDE System Setings to be generic 104 key EN-US, which is what we have here. I Set this to Microsoft Comfort Curve 2000, without any difference.

  • XFCE4 typing works fine.

Any idea how to diagnose this further?

Must have been something screwed up in Plasma…I did a reset using the following script:

cd ~/
rm -rf .kde
rm -rf .cache/plasmashell*
rm -rf .cache/org.kde.dirmodel-qml.kcache
rm -rf .cache/kioexec/ .cache/krunner/ .cache/ksycoca5*
rm -rf .cache/krunnerbookmarkrunnerfirefoxdbfile.sqlite
rm -rf .config/plasma*
rm -rf .config/kde*
cd .local/
rm -rf kate/ kded5/ klipper/ knewstuff3/ kscreen/ konsole/ kwalletd/ ksysguard/ kmail2/ kcookiejar/ kactivitymanagerd/
cd share/
rm -rf dolphin kate kcookiejar kded5 keyrings klipper kmail2 knewstuff3 konsole kscreen ksysguard kwalletd kxmlgui5 plasma_engine_comic plasma plasma_notes org.kde.gwenview
cd ~/.config/
rm -rf akonadi* KDE kconf_updaterc baloo* dolphinrc drkonqirc gwenviewrc kmail2rc k*rc katemetainfos

And it works now.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.