Keyboard shortcuts keep resetting

Heyo. My keybind for Application menu (I use cmd + space) keeps resetting. After every wakeup it’s gone and I have to reset it. One thing to note is that whenever I set it, it doesn’t even require the space key, I can just press command and the Application menu will open.

What do you mean CMD key? Are you using a mac?
Or do you actually mean the Windows key (it’s called SUPER-Key)?

KDE calls it the “meta” key. But yes. “Cmd”, “Super”, “Apple”, “Windows” key… whatever you want to call it. It keeps resetting. And it seems to be the only keybind that is resetting.

I was not being pedantic here, the win key has special behaviour, that’s why i needed to clear this beforehand.

I have only worked with XFCE on this but it might work on KDE also.

I use a program called ksuperkey, which I add to the system startup. The issue this fixes is that the win-key, when assigned to the menu, does not work as a key modifier any longer, thus any key combo that uses Win-key as a modifier will launch the menu instead.

About persistence, how are you binding the key?

System settings -> shotcuts -> global shortcuts -> plasma -> activate application menu -> custom shortcut

I don’t have a problem with any other shortcut that uses the same key as a modifier.

As stated here… you should probably set the key with right click on the KDE-icon (application menu) → application menu settings → keyboard shortcuts tab → shortcut. Or you leave it as it is… just the meta (win- whatever)-key. :smiley:

This looks promising. I’m using the latte dock aswell. Going to look into it.

DevNul’s tip worked. Multiple sleep/wakes, reboots and updates and shortcut hasn’t reset yet. Of course the solution had to be stupid simple. :smiley:

1 Like