Keyboard shortcuts don't work with virtualbox under Wayland

They do work in X11 but not in Wayland. Same results with every linux distro tried. Not a eos related issue in anyway as same happened in manjaro host. any suggestions ?

Looks like a known thing related to how the Wayland compositor handles keyboard/mouse input. You can read some details about it in this VBox ticket:

The ticket is two years old and hasn’t seen any updates, but it also points to a few links where apparently Gnome/Gnome Boxes has been able to overcome the issue and handle these inputs.

Finally, FWIW, I use Gnome/Wayland with libvirt/virt-manager and don’t think I have run into any shortcut issues for guest OSes (maybe I am just not using shortcuts).

Thanks. I will give virt-manager a try then.

I found this helpful when I was setting up virt-manager…

Thanks a lot @MrToddarama. I have setup virt-manager today and it feels good. Only one problem that how can I auto resize the display. There is a options in scale but it is greyed out. I can create a new topic if you suggest.

Sorry for an answer that is sort of a non-answer. Hopefully it doesn’t come across as “read the fine manual” :grinning:

Some web searches on libvirt guest resizing will point you in the right direction. Here is one link with a discussion you might want to read through: Virt Manager Guest Resize not Working

There is a lot of generally good libvirt info available from RedHat here : RedHat Virtualization Tuning and Optimization Guide

Finally, you will want to look into some of the documentation on Spice agents: Spice Page