Keyboard & power button stops working & laptop refuses to shutdown no matter what

Hello, I’ve been having a problem where my laptop’s built-in keyboard and power button stop working seemingly at random.
Trying to shut down with the power button doesn’t work,[systemctl poweroff/restart]/shutdown, reboot and trying doesn’t work, after systemd finishes up with everything laptop stays on with a black screen. Tried rebooting with sysrq as well and would immediately go to the black screen, and the only way to close it was to remove the battery. I’m on kde plasma with nvidia optimus & btrfs if it matters.
I’ve tried different kernels and would keep happening, and don’t know where/how to look for logs or sth to see what’s actually wrong.

Welcome to the forum! :partying_face:

First things first, could it be some sort of hardware failure, did you try to do a hardware test via bios menu?

Doesn’t appear to be since it has only ever happened on linux, never on windows. I’m dual booting them but mostly spend my time on linux nowadays.
Either way my bios doesn’t have a hardware test…

Ok! Just wondering did you have any issues with other distros? Just wondering whether your hardware is supported on linux or not. Never had problems with keyboard or power buttons before.

If you list more infos on your system that would help. Please click on the top menu (this forum webpage) Help>Forum log tool, which will guide you through it.

Don’t remember it happening on manjaro or pop!os, didn’t stay on them for long tho, did happen on garuda that I’ve been on for months & now here I am for over a month.
Also is the hardware information system the one you asked for?

inxi -Fxxc0z --no-host | curl -F ‘f:1=<-’