Keyboard lagging while typing

my keyboard from time to time skips inputs or doubles inputs, and i don’t know why.
sometimes it almost feels like my keyboard is ghosting (doesn’t happen on windows tho)

i’m running an i7 12700f with a amd rx580 card with gnome, which defaults to wayland
I’ve read, that disabling psr fixes the issue on intgrated intel gpus, but i don’t know how and if it will fix it on my system

Note: i’ve recently upgraded from a ryzen 5 2600x to the i7 1200f. before the upgrade this wasn’t an issue

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Most Desktops have in their settings menu ways to adjust the timing and sensitivity of the mouse and keyboard. Window Managers usually will require making changes in the configuration files.

So we need to know which DE or WM you are using.

In KDE here is where to look.
Play with the Delay and Rate settings.


hey thanks for the quick help,
as i already wrote, i’m using gnome, specifically gnome 42,
i figured it was a bluetooth problem

You can try adding the following kernel parameter in the default grub command line in /etc/default/grub



Then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg