Keyboard issue, extremely weird :D

Gnome (wayland) works fine, but Plasma X11, if I press Shift+4, I expect to get a dollar sign, but I get a ‘@’ sign.

Every other key works fine. I removed all keyboard mods and rebooted, still doesn’t work. Possibly the worst key in the world to loose :exploding_head:

Hmm …I just tried it and it works on my plasma. :thinking:

What do you get on shift 3?

As I said, everything is working except shift+4:

!"£@%^&*()

Should be:

!"£$%^&*()

(I just wrote an espanso definition to trigger a $ sign)

Something else, if caps lock is on I get $@…

Do you have set EN United Kingdom?

Yup, hence the flag :smiley:

localectl status
   System Locale: LANG=en_GB.UTF-8
       VC Keymap: uk
      X11 Layout: gb
       X11 Model: pc105

1 Like

Why i asked is because that i read that it showed the £ for shift 3. So i just wondered because they were talking about the shift keys becoming shift and shift 2 when using this?

Well Ctrl+Shift+4 generates a $ in the terminal, but not here :frowning: or in emacs!!!

Sorry @ricklinux not a clue what you are asking???

1234567890
!"£@%^&*()

@ should be a $ sign, not an @ symbol

The espanso trigger I wrote is:

  - trigger: "££"
    replace: "$"

I’m not really asking anything. I just read on another site about EN United Kingdom keyboard layout was changing shift & shift 2 key. I was just curious if it was set to that language setting? Obviously you’ve been using it that way and it was working before.

Yes i understand

@ should be a $ sign, not an @ symbol

1 Like

Gnome wayland is fine so it can’t be a keyboard failure, but am going to try bspwm and others. Back in a bit!!

Bspwm fine, openbox not. The only thing I can think of is I installed Trinity, have removed it and all traces and rebooted.

Next - try a new user, but time to eat :hamburger:

OK, new user works fine, Trinity related issue solved (I had set a global variable in /etc/environment), so I am going to reset plasma, but tomorrow :smiley:

Temporary fix:

xmodmap -e "keycode  13 = 48 dollar 48 dollar"

More strangeness though, it will not work as part of my .Xmodmap file, but will at the end of my script, so I suppose that gives me a little pointer in where to look :exploding_head:

1 Like