Keyboard is not working for username and password input in the login screen

I have installed EndeavourOS_Galileo-Neo-2024.01.25 and everything seems to work fine but at the screen to enter username and password the keyboard no longer works.

This is a PC with a USB keyboard, any suggestions? I can access the EndeavourOS files via the live versions.

I thank you for your suggestions.

I had this once or two iirc … in one of the machines.
I changed the connection of the usb cord of the keyboard to another port (blue to black or teal, vice versa etc ) and it started to work.

It’s not very scientific, but sometimes, electronics play with us :wink:

1 Like

Have you tried using other usb ports to connect the keyboard to when booting. Or tried another keyboard?

1 Like

if keyboard only works on live-ISO it looks like some regression to me.
But you could try getting some more info by starting liveiso and open terminal typing:
journalctl -f
this will live showing the journal messages… now plug off keyboard and plug it back in it could show some issue warning error…
in addition show some hardware specifications:

inxi -Fxxc0z | eos-sendlog

Hi

I agree that if the keyboard works in the live version it should be fine even after the final installation:

I entered the commands you posted, and here is the result:

[liveuser@eos-2024.01.25 ~]$ journalctl -f

journalctl -f
Feb 27 15:34:33 EndeavourOS audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus-:1.3-org.kde.kded.smart@0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 27 15:34:33 EndeavourOS kernel: audit: type=1131 audit(1709048073.311:116): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus-:1.3-org.kde.kded.smart@0 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 27 15:34:33 EndeavourOS plasmashell[746]: file:///usr/lib/qt/qml/org/kde/plasma/extras/PlaceholderMessage.qml:238:5: QML Heading: Binding loop detected for property "verticalAlignment"
Feb 27 15:34:38 EndeavourOS systemd[592]: Started Konsole - Terminal.
Feb 27 15:34:38 EndeavourOS plasmashell[746]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:286: Unable to assign [undefined] to QString
Feb 27 15:35:12 EndeavourOS qdbus[992]: Cannot find 'org.kde.KSplash.setStage' in object /KSplash at org.kde.KSplash
Feb 27 15:35:12 EndeavourOS systemd[592]: Finished KSplash "ready" Stage.
Feb 27 15:35:17 EndeavourOS plasma_waitforname[676]: org.kde.knotifications: WaitForName: Service was not registered within timeout
Feb 27 15:35:17 EndeavourOS systemd[592]: dbus-:1.2-org.kde.KSplash@0.service: Main process exited, code=exited, status=1/FAILURE
Feb 27 15:35:17 EndeavourOS systemd[592]: dbus-:1.2-org.kde.KSplash@0.service: Failed with result 'exit-code'.
Feb 27 15:38:58 EndeavourOS systemd-networkd[529]: wlan0: Link DOWN
Feb 27 15:38:58 EndeavourOS NetworkManager[528]: <info>  [1709048338.5535] device (wlan0): set-hw-addr: set MAC address to 5E:29:06:33:32:19 (scanning)
Feb 27 15:38:58 EndeavourOS systemd-networkd[529]: wlan0: Link UP
Feb 27 15:38:58 EndeavourOS NetworkManager[528]: <info>  [1709048338.6876] device (wlan0): supplicant interface state: disconnected -> interface_disabled
Feb 27 15:38:58 EndeavourOS NetworkManager[528]: <info>  [1709048338.7018] device (wlan0): supplicant interface state: interface_disabled -> inactive
Feb 27 15:39:26 EndeavourOS kernel: usb 3-4: USB disconnect, device number 3
Feb 27 15:39:26 EndeavourOS systemd-homed[469]: block device /sys/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0/host9/target9:0:0/9:0:0:0/block/sdd/sdd1 has been removed.
Feb 27 15:39:26 EndeavourOS systemd-homed[469]: block device /sys/devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0/host9/target9:0:0/9:0:0:0/block/sdd has been removed.
Feb 27 15:39:26 EndeavourOS kded5[692]: kf.solid.backends.udisks2: Error getting props: "org.freedesktop.DBus.Error.UnknownMethod" "Object does not exist at path “/org/freedesktop/UDisks2/drives/WDC_WD10EAVS_00M4B0_WD_WCAV51585209”" for "/org/freedesktop/UDisks2/drives/WDC_WD10EAVS_00M4B0_WD_WCAV51585209"
Feb 27 15:39:26 EndeavourOS kded5[692]: kf.solid.backends.udisks2: Error getting props: "org.freedesktop.DBus.Error.UnknownMethod" "Object does not exist at path “/org/freedesktop/UDisks2/drives/WDC_WD10EAVS_00M4B0_WD_WCAV51585209”" for "/org/freedesktop/UDisks2/drives/WDC_WD10EAVS_00M4B0_WD_WCAV51585209"
Feb 27 15:39:26 EndeavourOS plasmashell[746]: kf.solid.backends.udisks2: Error getting props: "org.freedesktop.DBus.Error.UnknownMethod" "Object does not exist at path “/org/freedesktop/UDisks2/drives/WDC_WD10EAVS_00M4B0_WD_WCAV51585209”" for "/org/freedesktop/UDisks2/drives/WDC_WD10EAVS_00M4B0_WD_WCAV51585209"
Feb 27 15:39:26 EndeavourOS plasmashell[746]: kf.solid.backends.udisks2: Error getting props: "org.freedesktop.DBus.Error.UnknownMethod" "Object does not exist at path “/org/freedesktop/UDisks2/drives/WDC_WD10EAVS_00M4B0_WD_WCAV51585209”" for "/org/freedesktop/UDisks2/drives/WDC_WD10EAVS_00M4B0_WD_WCAV51585209"
Feb 27 15:39:26 EndeavourOS plasmashell[746]: file:///usr/lib/qt/qml/org/kde/plasma/extras/ExpandableListItem.qml:291: TypeError: Cannot read property 'enabled' of null
Feb 27 15:39:26 EndeavourOS kernel: sd 9:0:0:0: [sdd] Synchronizing SCSI cache
Feb 27 15:39:26 EndeavourOS kernel: sd 9:0:0:0: [sdd] Synchronize Cache(10) failed: Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
Feb 27 15:39:47 EndeavourOS kernel: usb 3-4: new high-speed USB device number 6 using xhci_hcd
Feb 27 15:39:48 EndeavourOS kernel: usb 3-4: New USB device found, idVendor=1058, idProduct=1103, bcdDevice=10.28
Feb 27 15:39:48 EndeavourOS kernel: usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Feb 27 15:39:48 EndeavourOS kernel: usb 3-4: Product: My Book
Feb 27 15:39:48 EndeavourOS kernel: usb 3-4: Manufacturer: Western Digital
Feb 27 15:39:48 EndeavourOS kernel: usb 3-4: SerialNumber: 57442D574341563531353835323039
Feb 27 15:39:48 EndeavourOS kernel: usb-storage 3-4:1.0: USB Mass Storage device detected
Feb 27 15:39:48 EndeavourOS kernel: scsi host9: usb-storage 3-4:1.0
Feb 27 15:39:48 EndeavourOS kernel: input: Western Digital My Book as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.1/0003:1058:1103.0005/input/input24
Feb 27 15:39:48 EndeavourOS mtp-probe[1424]: checking bus 3, device 6: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-4"
Feb 27 15:39:48 EndeavourOS mtp-probe[1424]: bus: 3, device: 6 was not an MTP device
Feb 27 15:39:48 EndeavourOS kernel: hid-generic 0003:1058:1103.0005: input,hidraw1: USB HID v1.11 Device [Western Digital My Book] on usb-0000:00:14.0-4/input1
Feb 27 15:39:48 EndeavourOS mtp-probe[1428]: checking bus 3, device 6: "/sys/devices/pci0000:00/0000:00:14.0/usb3/3-4"
Feb 27 15:39:48 EndeavourOS mtp-probe[1428]: bus: 3, device: 6 was not an MTP device
Feb 27 15:39:49 EndeavourOS kernel: scsi 9:0:0:0: Direct-Access     WD       My Book          1028 PQ: 0 ANSI: 4
Feb 27 15:39:49 EndeavourOS kernel: sd 9:0:0:0: [sdd] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
Feb 27 15:39:49 EndeavourOS kernel: sd 9:0:0:0: [sdd] Write Protect is off
Feb 27 15:39:49 EndeavourOS kernel: sd 9:0:0:0: [sdd] Mode Sense: 10 00 00 00
Feb 27 15:39:49 EndeavourOS kernel: sd 9:0:0:0: [sdd] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
Feb 27 15:39:49 EndeavourOS kernel:  sdd: sdd1
Feb 27 15:39:49 EndeavourOS kernel: sd 9:0:0:0: [sdd] Attached SCSI disk
Feb 27 15:39:49 EndeavourOS systemd[1]: Started dbus-:1.3-org.kde.kded.smart@1.service.
Feb 27 15:39:49 EndeavourOS audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus-:1.3-org.kde.kded.smart@1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 27 15:39:49 EndeavourOS kernel: audit: type=1130 audit(1709048389.628:117): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus-:1.3-org.kde.kded.smart@1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 27 15:39:50 EndeavourOS plasmashell[746]: file:///usr/share/plasma/plasmoids/org.kde.plasma.devicenotifier/contents/ui/DeviceItem.qml:36:5: Unable to assign [undefined] to bool
Feb 27 15:39:50 EndeavourOS plasmashell[746]: file:///usr/share/plasma/plasmoids/org.kde.plasma.devicenotifier/contents/ui/DeviceItem.qml:35:5: Unable to assign [undefined] to bool
Feb 27 15:39:50 EndeavourOS plasmashell[746]: trying to show an empty dialog
Feb 27 15:39:50 EndeavourOS plasmashell[746]: trying to show an empty dialog
Feb 27 15:39:50 EndeavourOS plasmashell[746]: trying to show an empty dialog
Feb 27 15:39:50 EndeavourOS plasmashell[746]: Qt Quick Layouts: Detected recursive rearrange. Aborting after two iterations.
Feb 27 15:39:50 EndeavourOS plasmashell[746]: Qt Quick Layouts: Detected recursive rearrange. Aborting after two iterations.
Feb 27 15:40:00 EndeavourOS systemd[1]: dbus-:1.3-org.kde.kded.smart@1.service: Deactivated successfully.
Feb 27 15:40:00 EndeavourOS audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus-:1.3-org.kde.kded.smart@1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 27 15:40:00 EndeavourOS kernel: audit: type=1131 audit(1709048400.331:118): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus-:1.3-org.kde.kded.smart@1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
^C
[liveuser@eos-2024.01.25 ~]$ journalctl -f
Feb 27 15:39:50 EndeavourOS plasmashell[746]: file:///usr/share/plasma/plasmoids/org.kde.plasma.devicenotifier/contents/ui/DeviceItem.qml:36:5: Unable to assign [undefined] to bool
Feb 27 15:39:50 EndeavourOS plasmashell[746]: file:///usr/share/plasma/plasmoids/org.kde.plasma.devicenotifier/contents/ui/DeviceItem.qml:35:5: Unable to assign [undefined] to bool
Feb 27 15:39:50 EndeavourOS plasmashell[746]: trying to show an empty dialog
Feb 27 15:39:50 EndeavourOS plasmashell[746]: trying to show an empty dialog
Feb 27 15:39:50 EndeavourOS plasmashell[746]: trying to show an empty dialog
Feb 27 15:39:50 EndeavourOS plasmashell[746]: Qt Quick Layouts: Detected recursive rearrange. Aborting after two iterations.
Feb 27 15:39:50 EndeavourOS plasmashell[746]: Qt Quick Layouts: Detected recursive rearrange. Aborting after two iterations.
Feb 27 15:40:00 EndeavourOS systemd[1]: dbus-:1.3-org.kde.kded.smart@1.service: Deactivated successfully.
Feb 27 15:40:00 EndeavourOS audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus-:1.3-org.kde.kded.smart@1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Feb 27 15:40:00 EndeavourOS kernel: audit: type=1131 audit(1709048400.331:118): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=dbus-:1.3-org.kde.kded.smart@1 comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
^C   
[liveuser@eos-2024.01.25 ~]$ inxi -Fxxc0z | eos-sendlog
==> Info: 0x0 failed, trying dpaste ...
==> Info: dpaste failed, trying termbin ...
eos-sendlog-helper: error: configured pastebin services failed!
[liveuser@eos-2024.01.25 ~]$

[liveuser@eos-2024.01.25 ~]$ inxi -Fxxc0z | eos-sendlog
==> Info: 0x0 failed, trying dpaste …
==> Info: dpaste failed, trying termbin …
eos-sendlog-helper: error: configured pastebin services failed!
[liveuser@eos-2024.01.25 ~]$

I also tried unplugging the USB cable from the keyboard, and now the login screen no longer appears but just a black screen with the arrow in the middle, the mouse, which moving it works. Unfortunately, I don’t see anything else.

Maybe the problem is in the installer that generates some problem during installation.

Thanks very much for any suggestions

Can you use code tags around the ouput you post? It makes it much easier to read.

the journal liveoutput was not to be posted … only for you to check…
anyway …

you should try that again:
inxi -Fxxc0z | eos-sendlog
seems you had connection issue or no internet connection…

you where unpluggi9ng the keyboard while the livejournal was running?

As i do see an usb harddrive unplugged only…

usb 3-4: USB disconnect, device number 3
Product: My Book

may you also have simply done something wrong with the installation… you could sens the installer log if possible… but make sure it is the one from installed system you can find under /var/log/endeavour-install.log on the installed system indeed not the livesession path… you will need to open the root device/partition form installed system inside filebrowser and open it …

This is the log file of the installation, the language is Italian:


I received an error in entering the log file as it is too large 360000 characters only 90000 characters are accepted.

I think I will have to wait for the next version of endeavour.

I thank you for your assistance.

I do not think the main issue here is about an error on the ISO or install process.
Next ISO will be the same.

The issue is that you was not able to provide the needed info, it does not make sense to post logs as text inside a post no one is able to read that.
code tags is an option in the editor:
2024-02-27_20-07

And i have to add that i really do not think EndeavourOS is for everyone, a lot of users will be more happy with something more hand holding and fool proof.

You will need some deeper understanding about the internals of Linux and Hardware, to easily run EndeavourOS.

1 Like