Keyboard and touchpad settings not saving

Hello! Another newbie here using EndeavourOS to get a feel for Arch. So far, I’m really enjoying it, and it’s doing a better job of gently pushing me to learn more about the system than Manjaro did. With that said, I’ve run into two issues:

  1. I’m running the OS on an old laptop with a non-English keyboard layout (an old Macbook Pro in case it’s relevant). Despite selecting said layout during the installation process, the settings seemed to jump back to the English default layout upon booting into the actual system. I actually wound up having to reinstall the OS within a few minutes because my original password contained non-English characters. Even after seemingly fixing the settings, the XFCE terminal still assumes an English layout (meaning dashes and such aren’t where they’re marked on my keys); and as right as I was in the process of typing up this post, I discovered that the layout’s hopped back to English again.

  2. Changes to the touchpad settings aren’t saving at all. Checking the boxes for inverted scrolling and “tap to click” doesn’t seem to do anything. Change the settings, close the window, open it up again right away and they’re back to default.

You can try to configure libinput manually (assuming that you’re using libinput). What’s the content of ls /usr/share/X11/xorg.conf.d/ ?

Content of ls /usr/share/X11/xorg.conf.d/:

10-quirks.conf 40-libinput.conf

Editing the latter manually seems to have taken care of it. Thanks! For the benefit of people with the same problem, I added Option “Tapping” “on” and Option “NaturalScrolling” “true” to the section pertaining to the touchpad.

Any idea if there’s a similar fix for the keyboard issues?

You can try to change the layout with setxkbmap. Try setxkbmap <layout> (for example setxkbmap fr) and check whether it works as expected. It will only work for the current session, but you can make it permanent (when starting X) by adding the line above to your ~/.xprofile. I am not sure though that it will work inside the DM, so entering the password will probably still be complicated…

edit: actually there are several ways to do it. You can check this out - https://wiki.archlinux.org/index.php/Xorg/Keyboard_configuration and see what suits you best.

1 Like

setxkbmap worked, and I’ve (hopefully) set it to run in ~/.xprofile. Thanks again!

1 Like