Keyboard and mouse not working when booting but work afterwards

I’m not sure if this belongs here but I have an issue with my keyboard and mouse not working in the boot menu (making it impossible to change what OS to boot into) and continues for about ten-ish seconds on the login screen (SDDM) where I can’t use either my mouse or keyboard. Also the issue only occurs if I ton my system on, rebooting everything works fine till I turn it back off.
Not sure how to fix this issue so if anyone has any idea, appreciate it.

System is (according to neofetch):
OS: EndeavourOS Linux x86_64
Kernel: 5.16.2-arch1-1
DE: Plasma 5.23.5
WM: KWin
CPU: AMD Ryzen 9 5900X (24) @ 3.700GHz
GPU: NVIDIA GeForce RTX 3060
Memory: 4291MiB / 15964MiB

Does the keyboard work in the BIOS?

If not, it’s a hardware issue that can’t be fixed by any setting in EnOS (try different ports, connecting directly rather than via a USB hub, try a different keyboard, etc.).


Tried different keyboard and mouses, they do not work in the grub boot menu and take a couple of seconds to become usable when OS loads. It does work in the Windows boot manager so I’m pretty sure it’s an issue with either some configuration or a bug but I don’t know what to try to fix it.

Edit: Also tried different USB ports as well but I was pretty sure that wouldn’t work.

Fixed it by changing fastboot from ultra fast to disable in the UEFI

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.