Keyboard Alt-gr functionality suddenly changed

Something weird going on with my keyboard layout.

Alt-gr + number 2 key used to trigger the (at) symbol and Alt-gr + E key used to trigger the euro symbol. Now there seems to be no way to trigger those symbols. Same applies for the dollar symbol for example or the “spanish N”.

When I’m on a web browser, like I currently am, if I press Alt-gr + 2 (for the at symbol) the browser switches to the 2nd tab from the left.

I’ve tried removing keyboard layouts, changing locales etc. No effect.

Here’s my -inxi:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB:en_US:fi",
        LC_ALL = (unset),
        LC_ADDRESS = "fi_FI.UTF-8",
        LC_NAME = "fi_FI.UTF-8",
        LC_MONETARY = "fi_FI.UTF-8",
        LC_PAPER = "fi_FI.UTF-8",
        LC_IDENTIFICATION = "fi_FI.UTF-8",
        LC_TELEPHONE = "fi_FI.UTF-8",
        LC_MEASUREMENT = "fi_FI.UTF-8",
        LC_CTYPE = "fi_FI.UTF-8",
        LC_TIME = "fi_FI.UTF-8",
        LC_COLLATE = "fi_FI.UTF-8",
        LC_NUMERIC = "fi_FI.UTF-8",
        LANG = "en_FI.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:
  Kernel: 5.18.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=33b92acc-eae1-4daf-86a1-a400c31bc857 rw rootflags=subvol=@
    splash intel_iommu=on rd.udev.log_priority=3 vt.global_cursor_default=0
    systemd.unified_cgroup_hierarchy=1 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: ASRock model: Z370 Gaming-ITX/ac
    serial: <superuser required> UEFI: American Megatrends v: P4.30
    date: 11/01/2019
Battery:
  Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 built: 2018 process: Intel 14nm family: 6 model-id: 0x9E (158)
    stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 2163 high: 3477 min/max: 800/5000 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1217 2: 2183 3: 2612
    4: 3477 5: 1667 6: 2138 7: 1664 8: 2952 9: 2509 10: 2075 11: 2033
    12: 1439 bogomips: 88796
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
Graphics:
  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] vendor: ASRock
    driver: i915 v: kernel arch: Gen9.5 process: Intel 14nm built: 2016-20
    ports: active: DP-3 empty: DP-1, DP-2, DP-4, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:3e92 class-ID: 0300
  Device-2: NVIDIA GP104 [GeForce GTX 1070] vendor: Gigabyte driver: nvidia
    v: 510.68.02 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-06) arch: Pascal process: TSMC 16nm
    built: 2016-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none
    off: DP-5 empty: DVI-D-1,DVI-D-2,HDMI-A-3 bus-ID: 01:00.0
    chip-ID: 10de:1b81 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.83x15.00")
    s-diag: 987mm (38.84")
  Monitor-1: not-matched mapped: DP-0 size-res: N/A modes: N/A
  Monitor-2: not-matched mapped: DP-1-3 pos: primary res: 3440x1440
    dpi: 107 size: 819x346mm (32.24x13.62") diag: 889mm (35") modes: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
Audio:
  Device-1: Intel 200 Series PCH HD Audio vendor: ASRock
    driver: snd_hda_intel v: kernel bus-ID: 1-5.3:6 bus-ID: 00:1f.3
    chip-ID: 1038:1297 chip-ID: 8086:a2f0 class-ID: 0300 class-ID: 0403
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f0 class-ID: 0403
  Device-3: SteelSeries ApS Arctis Pro Wireless type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.18.3-zen1-1-zen running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter
    vendor: Apple driver: wl v: kernel modules: bcma pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 04:00.0 chip-ID: 14e4:43a0
    class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth:
  Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb
    v: 0.8 bus-ID: 1-14.3:11 chip-ID: 05ac:828f class-ID: fe01
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.67 TiB used: 2.36 TiB (88.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: R0906I
    temp: 44.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 2B6Q scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: A-Data model: SU800 size: 1.86 TiB
    block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
    serial: <filter> rev: 7A
  ID-4: /dev/sdc maj-min: 8:32 vendor: Samsung model: SSD 840 PRO Series
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 6B0Q scheme: GPT
Partition:
  ID-1: / raw-size: 39.26 GiB size: 39.26 GiB (100.00%)
    used: 26.04 GiB (66.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 560 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 437.18 GiB size: 437.18 GiB (100.00%)
    used: 433.94 GiB (99.3%) fs: btrfs dev: /dev/nvme0n1p3 maj-min: 259:3
  ID-4: /var/log raw-size: 39.26 GiB size: 39.26 GiB (100.00%)
    used: 26.04 GiB (66.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 39.26 GiB size: 39.26 GiB (100.00%)
    used: 26.04 GiB (66.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 31.03 GiB used: 2.5 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A gpu: nvidia temp: 40 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 39%
Info:
  Processes: 375 Uptime: 1h 23m wakeups: 5 Memory: 31.03 GiB
  used: 5.34 GiB (17.2%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages:
  note: see --pkg pacman: 1974 lib: 587 Shell: Zsh v: 5.9 running-in: konsole
  inxi: 3.3.17
Garuda (2.6.3-2):
  System install date:     2021-05-05
  Last full system update: 2022-06-13
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Timeshift
  Failed units:            samba.service systemd-guest-user.service 

Yes, I’m on Garuda. But I think this is Plasma related, so it shouldn’t matter.

It seems like it is likely related to this.

What does localectl show?

localectl shows this:

System Locale: LANG=en_GB.UTF-8
                  LANGUAGE=fi_FI.UTF-8
                  LC_CTYPE=fi_FI.UTF-8
                  LC_NUMERIC=fi_FI.UTF-8
                  LC_TIME=fi_FI.UTF-8
                  LC_COLLATE=fi_FI.UTF-8
                  LC_MONETARY=fi_FI.UTF-8
                  LC_PAPER=fi_FI.UTF-8
                  LC_NAME=fi_FI.UTF-8
                  LC_ADDRESS=fi_FI.UTF-8
                  LC_TELEPHONE=fi_FI.UTF-8
                  LC_MEASUREMENT=fi_FI.UTF-8
                  LC_IDENTIFICATION=fi_FI.UTF-8
       VC Keymap: fi
      X11 Layout: fi
       X11 Model: logitech_base
     X11 Variant: nodeadkeys

Which is weird, because in my inbput → keyboard → layout settings it’s different:

Try running

sudo locale-gen

and see if that fixes it. Perhaps reboot, too…

This was one of the first things I tried. No change.

This is the Plasma/KDE keyboard layout (user’s), while localectl shows the system’s layout.
The expected behavior should work when you switch to fi layout, while what you report as not working as expected is because you probably have en layout active.

Ok that’s good to know. I found an option for finnish-english layout in System Settings->Regional Settings->Formats->Region.

Use what works for your preference, after testing.
My previous comments are from experience from my Greek-English keyboard layouts.

I found the solution, had to set the Region to Finnish under the Formats. It must have changed during an update, I have not touched those settings in months.

FYI these local (user) configuration is not affected by updates.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.