Kernel parameters for linux-lts

I’ve set the following parameter. I mainly use linux or linux-zen (not so often).

radeon.si_support=0 amdgpu.si_support=1 loglevel=3 quiet nowatchdog

(I don’t know what the loglevel means).

I want to set the linux-lts to load with radeon.si_support=1 amdgpu.si_support=0 to test a weird problem with a white screen I have. I know about pressing e on boot up, but is there a permanent way and only for the lts kernel?

Hello @jimmy213

Loglevel 3 is kernel error that notifies you about non-critical errors. Are you using radeon drivers or amdgpu because the parameters you have just turn off radeon support and turn on amdgpu support. Not needed if you are using amdgpu. Not sure about the issue you have with white screen?

I think more information would be needed on your issue with respect to the white screen. You can add these parameters to the default grub command line in /etc/default/grub and then regenerate the grub file with sudo grub-mkconfig -o /boot/grub/grub.cfg but i think that will be used for both kernels on boot as this makes them permanent.

yes you can update
/etc/default/grub

and for update

sudo grub-mkconfig -o /boot/grub/grub.cfg

Can you be more clear about how you can update /etc/default/grub so that the changes apply to one kernel and not other kernels?

@ricklinux I’m using amdgpu mainly because of Vulkan/DXVK. So I set the first parameter because by default, the radeon was being loaded.

About the white screen (I’m thinking of opening a separate thread about that), randomly (while coding, watching a movie or just browsing), my screen turns white and the system freezes (?). Music stops playing and I have no mouse cursor. Because I’m having an interview on Friday, I don’t want this to happen. So I thought to test if that happens with the radeon driver too (I don’t know if linux-lts makes a difference in this case).

@Stephane I know how to edit/update grub and I added the parameter I showed above. I was just wondering if it’s possible to set a parameter (a modification of the above) for a specific kernel (linux-lts) and not for all (as I do now).

Maybe you can but I’m not aware how to do that. Probably it would have to be done in the actual grub boot file that is generated? Not sure? There is now just an update to mesa also so maybe that helps.

1 Like

I guess a feasible way to do this is to add a custom script to /etc/grub.d/ which adds an extra boot entry just for your testing. But dont ask me how to do that.

You can find some hints on the web. E.g.

https://forums.linuxmint.com/viewtopic.php?t=123539

1 Like

Easiest way is to create a custom boot entry.

First, find your generated linux-lts entry in /boot/grub/grub.cfg.

It will look something like this …

menuentry 'EndeavourOS, on linux-lts' --class endeavouros --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-lts-advanced' {
    ...
    echo 'Loading kernel linux-lts ...'
    linux /boot/vmlinuz-linux-lts [kernel-parameters]
    echo 'Loading initial ramdisk ...'
    initrd /boot/amd-ucode.img /boot/initramfs-linux-lts.img
}

Copy this entry and paste it into /etc/grub.d/40_custom.

Manually modify the [kernel-parameters] section with whatever you want changed. Probably best to change the menuenty name to something custom too.

Regenerate grub and you will now have an extra menu option for linux-lts with the different kernel parameters.

5 Likes

Thank you very much. It worked just as I wanted.
I named it radeon-lts just to keep the linux-lts “clean”.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.