Kernel panic

So I tried logging in and this popped up…

Loading linu linux- lts…
error : file ‘/vmlinuz-linux-lts’ not found.
Loading initial ramdisk…
error : you need load the kernels first.

Press any key to continue…

I found what looks like a workable solution here:

BUT: I was told I must be a “supervisor” to mount. Am I missing something simple here or is there something more going on? Any advice would be appreciated.

Read this too.

1 Like

This is not a kernel panic that you describe, so you should better change the topic title to something else.

Your bootloader is trying to find the kernel, which is configured to be on a /boot separate partition.
For some reason, probably some miscofiguration, it cannot find the kernel, so the system (Linux/Archlinux/EnOS) cannot start.

You haven’t explained how did you install your system, and what configuration you have selected during installation (mainly regarding system partitions).
Give more info, so you can get a more specific advice.

PS: Since this is not a kernel panic, the article you have tried to follow cannot help at all in your issue. Just out of curiosity, who told you you must be a supervisor to mount?

1 Like

Thanks for that. Its fundamentally the same article. The problem is I’m being told I must be supervisor to mount. Its an issue of permissions.

Did you, by any chance, accidentally uninstall your lts kernel? What about other kernels? Does your system boot if you select other kernels from the boot menu?

1 Like

You have to use sudo in order to mount partitions. So if you are trying to arch-chroot? If following google search results a lot of information given makes assumptions on the knowledge of the user.

Yes I worked that out but the process is still not working as planned. You are right these articles often assume a lot of prior knowledge the user may not have.

Now that’s the interesting part. This is the second time this has happened. Last time I simply used the fall back from grub menu. This time around “only” the LTS kernel is present and its not working.

It might be a full re-install is called for. Thankfully I backed up all important files to USB.

Have you tried reinstalling grub and updating grub after from arch-chroot?

1 Like

Sometimes when you stop the update in between, the initramfs is not created so the distro won’t boot.

As @ricklinux said the best way to solve the issue is chrooting into the install using an ISO and recreating the initramfs by reinstalling the kernel.

Complete reinstall of the distro isn’t needed.

1 Like

Yes I just have but now the kernel is missing…I suspect I have messed up badly but then this is hardly an easy fix… :sweat_smile:

I think I’ll re-install and accept I should really have fully backed up using Timeshift…

As @sradjoker said have you tried reinstalling the kernel in that process?


As in you checked the directory inside your efi partition and the vmlinuz file is missing? In that case, you should just reinstall the kernel like rick said.

1 Like

It is an easy enough fix if you learn how to arch chroot. It won’t take more than 10 minutes. We’ll guide you through many. Many people here are quite familiar with the process

Start with the instructions here

additional resources:

After you manage to arch-chroot, just reinstall the kernel:

pacman -S linux-lts linux-lts-headers
1 Like

Yes its working again. Reinstalled kernel and re-created config file for grub boot loader. Appreciate the assist everyone. Lean’t something new today… :wink:

For anyone new-lish like me, here’s the full commands:

sudo pacman -S linux-zen linux-zen-headers (or lts-headers…etc)

sudo grub-mkconfig –o /boot/grub/grub.cfg


Oh, how you somehow didn’t mention that you use zen kernel. :slight_smile: The point is that it works. Does your machine start now even with a normal, non-LTS kernel?

I’m familiar with the process for swapping between LTS, Zen, kernel from default. At the time I posted this I was using LTS. I have used Zen in the past. This was just an example for someone else who faced this issue and was relatively new.

The problem for me was understanding how to fix this from the USB, mounting, permissions, etc. I now have documented this and now know exactly what to do, should it happen again.

Again thanks to all who offered their help and suggestions. Much appreciated. :slight_smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.