Kernel panic with Endeavor boot

After successful installations of both EndeavorOS alongside PopOS, both of which booted up quite nicely, I installed Mint on a third partition successfully, but upon a restart, selecting EndeavorOS (this is the latest ISO from 17-Aug), I get a kernel panic as seen in the attached photo. Both Mint and PopOS will boot. I can get EndeavorOS to boot successfully using its previous installation via “Advanced Options”. From that EndeavourOS boot, I tried doing a “grub-mkconfig -o /boot/grub/grub.cfg”, but the default EndeavourOS boot still generates the same kernel panic. Is this a known issue with multibooting with Arch based distros? I have found some references to similar issues with Manjaro. Thanks for any suggestions. Photo 1 is the panic, photo 2 is the boot menu, photo 3 is the expansion of the EndeavourOS boot after entering “e”.

Change initrd amd-ucode.img, to initrd initramfs-linux.img in grub command line and reinstall grub, this issue ocurred on my system in update antergos to arch.

2 Likes

Hi!
Looks like you installed mint grub, overwriting endeavour’s, so updating grub at endeavour won’t work.
If this is the case then is mint grub that is unable to detect endeavouros.

Try updating grub at mint just in case. sudo update-grub

1 Like

Thanks! That did the trick. Now I just need to investigate exactly what Mint did to break things.

1 Like

Correct. Things were fine until Mint finished its install. I’d already attempted an update-grub from Mint, but Endeavour was still unable to boot. Xterminator’s suggestion above works, so just need to make that change permanent.

1 Like

Nice!

Since endeavour is new, is possible mint grub is not able to detect the system yet, though i’d think it should detect as archlinux at least.

You could also reinstall endeavour grub, but this choice is up to you. If your systems are fine better not try this :slight_smile:

The problem is a long standing one with grub and os-prober. Solutions have been proposed, but it seems that the two teams, grub team and os-prober team can’t come together and fix it.

It is the generation of the initrd line. Arch systems need two parameters there, and most others only one. Now, debian based generators provide only one parameter, and that is the issue.

So best practise is install Arch based system last and let it control booting.

3 Likes

i do have also hickups on detecting archbased from arch itself here :wink:

1 Like

In fact we have a working solution in EOS. Package grub-tools includes a program that fixes grub and os-prober. After running the fixer, grub generation works as it should.

And I guess the same fixer can fix grub in debian based systems as well!

3 Likes

We need a wiki for this tools too :slight_smile:

3 Likes

An informative wiki dealing with EFI bootloader issues with multi-booted systems would be very useful. In the past, particularly with Manjaro, the only issue I typically had after installing Manjaro on machines with pre-existing Linux OS’s was that Manjaro’s grub update obviated the pre-existing OS boot entries. I typically installed the “boot-repair” utility to get things back in order, and never had to deal with editing individual parameters with regard to the initd line or blacklisting drivers like nouveau. With the latest issue on my System76 laptop(s), having some of the most recent Nvidia hardware aboard, things have ramped up a bit. I find myself googling all over the place tracing down bits and pieces of relevant information. Having just purchased a System76 laptop has allowed me to interact more directly with the folks over there, who have apparently had some close collaboration with graphics hardware manufacturers like Nvidia and (soon) AMD. Of particular interest is this one from about a year ago from Francisco Soto on an Oryx Pro model like mine. Anyway, thanks forl your help in finding solutions to this to this. Here’s the link:

https://ebobby.org/2018/08/06/archlinux-nvidia-on-oryp4/

2 Likes

I’m glad you found a way to boot EOS on your machine with a very specific workaround. Thank you for the link and we certainly will use this information on a future Wiki article.

I have problems sometimes with grub in any distro, because on Desktop I have Fedora and Arch and Laptop I have Fedora, Fedora Rawhide and some test distro, at the moment debian 10 Buster because i needs to do some tests on Debian. Soon I will reinstall EndeavourOS.
I started noticing problems with grub only after the 5.1 kernel, I don’t know why, but os-prober give ioctl /dev/mapper error sometimes when I update grub in a terminal window, if I edit the grub command line line and start in runlevel 3, this does not happen, I am still trying to figure out what happens.