Kernel panic on shutdown

I’m experiencing a very strange kernel panic when I attempt to shutdown my system. Must have something to do with yesterday’s updates I think. Do you know how I can fix it?

Thanks!

Probably the only way you can avoid it (you can’t fix it most likely), is to use another kernel, either wait for the next or go back.

What were “yesterday’s updates” in the context of a rolling release distro?

Why do you think that?

Then please show us what was upgraded yesterday on your PC:

grep -E "2021-02-21.*\[ALPM\] upgraded" /var/log/pacman.log
(put the right date in that regex)

And for which kernel do you have that issue? Have you tried a different kernel?

Thank you for your replies.
I was running 5.10.16-arch1-1
On February 20th, the following packages were updated:

[2021-02-20T13:43:57+0100] [ALPM] upgraded kbd (2.3.0-2 -> 2.4.0-2)
[2021-02-20T13:43:57+0100] [ALPM] upgraded fwupd (1.5.6-1 -> 1.5.6-2)
[2021-02-20T23:50:33+0100] [ALPM] upgraded ca-certificates-mozilla (3.61-1 -> 3.62-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded gtk3 (1:3.24.25-1 -> 1:3.24.25-2)
[2021-02-20T23:50:33+0100] [ALPM] upgraded nss (3.61-1 -> 3.62-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded electron (11.2.3-1 -> 11.3.0-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded lib32-libgcrypt (1.9.1-1 -> 1.9.2-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded lib32-nss (3.61-1 -> 3.62-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded libgexiv2 (0.12.1-4 -> 0.12.2-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded libmaxminddb (1.5.0-1 -> 1.5.2-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded meson (0.57.0-1 -> 0.57.1-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded mkinitcpio (29-1 -> 30-1)
[2021-02-20T23:50:33+0100] [ALPM] upgraded rygel (1:0.40.0+6+g2843de82-1 -> 1:0.40.1-1)
[2021-02-20T23:51:17+0100] [ALPM] upgraded r8125-dkms (9.004.01-6 -> 9.005.01-1)

However, I switched to the zen-kernel and now I can shutdown and reboot properly. Only thing is, that now I have some messages at bootup saying No IRQ handler for vector, but I can live with that for a while.

The no IRQ vector handler may be resolved with a Bios update. I had it on my MSI Ryzen board until the latest update. Now it’s not present anymore.

I had it until kernel 5.10.14, where it dissapeared and after that it magically reappeared on 5.10.16 :man_shrugging:

I will try to update the Bios. Maybe it helps. I thought it had to do with the kernel instead.

I never had it originally until i updated to a newer UEFI Firmware (Bios). I updated a few times and then it appeared. The latest update which just came out recently for my AMD board fixed it.

Guess what?! The IRQ handler thing is vanished. But… as I wanted to reboot for my Bios update the kernel panicked again. Now, I am so far to be as zen as my kernel is. :smile:

I don’t understand what’s happening and why. Any suggestions?

This is the only package update that touches the kernel, so you can downgrade it to see if the issue persists.

If the issue is with this driver then you can report it upstream, but also keep in mind that it says it’s “for kernel up to 5.6” so if you want to use this driver then you might also want to try linux-lts54

However.

The package was removed from the AUR in November 2020 because “Package is no longer required due to kernel support in 5.9.1” - so do you actually need it?

2 Likes

I see, I forgot to share my specs:

My CPU: AMD Ryzen 5 5600X (12) @ 3.700G
My GPU: NVIDIA GeForce RTX 3060 Ti

linux-lts54 would not be recommended for me, because the Nvidia drivers wouldn’t work.
Actually, I installed r8125-dkms from the AUR, because my ethernet did not work with the preinstalled r8169 but with r8125-dkms.

So, sometimes shutdown and rebooting are working, sometimes not. Maybe I was just lucky before and it has nothing to do with my Feb 20 update.

There is a very easy way to find out.

This post was flagged by the community and is temporarily hidden.

I am not sure the sarcasm is really warranted in this case.

You can simply temporarily remove r8125-dkms and see if the problem is still there with the stock kernel. Then you will know for sure if it is related.

1 Like

Thank you @dalto and @jonathon, I removed r8125-dkms and now the kernel behaves normally.