Kernel panic in installation

Hello, I tried installing EndeavourOS but every time I boot into the installer it show me this error
kernel panic - not syncing: Attempted to kill init! exit code =0x00007e00

that’s an image for more info:

I only tried rebooting but nothing works, I tried searching for the
error code but I didn’t found anything at all

What do you use to create the live USB?

try using Ventoy and when booting choose “grub2 mode”

1 Like

I used Etcher.
I tried Ventoy and choosed grub2 mode, This time it showed a different error:

[    77.185700] sd 9:0:0:0 [sdd] tag#0 device offline or changed
[    77.185795] SQUASHFS error: Failed to real block 0x1855da0: -5

have you also tried in “normal mode”?

are you sure that the flash drive you are using is not faulty?

1 Like

Yes I’ve tried that
I’m not sure about the flash drive tho.

try using another flash drive if you can

unfortunately I don’t have another one

ventoy can be installed on an external hard disk instead of a flash drive…

i don’t have any external hard disk either xd
i’ll borrow or buy a flash drive later, i’ll tell you if the problem is solved or not when i do

1 Like

Just to discard a possible cause: did you check the integrity of the downloaded ISO to make sure if it is not damaged/corrupted?

Yes, I tried it on a virtual machine and it worked just fine

I found an old flash drive, i tried it and it works
thank you so much for helping :D.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.