Kernel Panic after update

Hey guys!

I always update my system at night before turning off my laptop. Recently I updated and started facing the kernel panic screen on boot. I tried to search more about this, but nothing helped me. Today I just downgraded to an old version of packages and it fix the kernel panic (aparently), and now I’m avoiding updating the system. What is the best way to fix this kernel panic?

System information:

  Kernel: 6.7.1-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: initrd=\7a5b7ac62a44443099e05bc3774f480c\6.7.1-arch1-1\initrd
    nvme_load=YES nowatchdog rw
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
    dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Dell product: Vostro 5402 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0TMFFT v: A00 serial: <superuser required> UEFI: Dell
    v: 1.21.0 date: 02/09/2023
  ID-1: BAT0 charge: 47.4 Wh (99.0%) condition: 47.9/53.0 Wh (90.4%)
    volts: 16.7 min: 15.0 model: BYD DELL TXD0314 type: Unknown serial: <filter>
    status: charging
  Device-1: hid-dc:2c:26:e3:c7:92-battery model: Keychron K8 serial: N/A
    charge: N/A status: discharging
  Info: model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 level: v4 note: check built: 2020
    process: Intel 10nm family: 6 model-id: 0x8C (140) stepping: 1
    microcode: 0xB4
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 596 high: 1400 min/max: 400/4700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 1400 4: 400
    5: 970 6: 400 7: 400 8: 400 bogomips: 27040
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB:
    conditional, RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Dell
    driver: i915 v: kernel arch: Gen-12.1 process: Intel 10nm built: 2020-21
    ports: active: HDMI-A-1,eDP-1 empty: DP-1 bus-ID: 00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA GP108M [GeForce MX330] vendor: Dell driver: nouveau
    v: kernel non-free: 545.xx+ status: current (as of 2023-10; EOL~2026-12-xx)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-2021 pcie:
    speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 2c:00.0
    chip-ID: 10de:1d16 class-ID: 0302
  Device-3: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:4 chip-ID: 0bda:5538
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.11 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,intel,nouveau,nv,vesa dri: iris,nouveau
    gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3520x1080 s-dpi: 96 s-size: 928x285mm (36.54x11.22")
    s-diag: 971mm (38.22")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary,top-right
    model: Dell AW2518HF serial: <filter> built: 2019 res: 1920x1080 dpi: 90
    gamma: 1.2 size: 544x303mm (21.42x11.93") diag: 623mm (24.5") ratio: 16:9
    modes: max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: bottom-l model: AU Optronics 0x453d built: 2018
    res: 1600x900 hz: 60 dpi: 132 gamma: 1.2 size: 309x174mm (12.17x6.85")
    diag: 355mm (14") ratio: 16:9 modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
    device: 2 drv: swrast surfaceless: drv: iris x11: drv: iris
    inactive: gbm,wayland,device-1
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.3-arch1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel Xe Graphics (TGL GT2)
    device-ID: 8086:9a49 memory: 15 GiB unified: yes
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:a0c8 class-ID: 0401
  Device-2: Kingston HyperX Cloud II Wireless
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 3-1:6 chip-ID: 0951:1718 class-ID: 0300
    serial: <filter>
  API: ALSA v: k6.7.1-arch1-1 status: kernel-api
    tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.1 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 2d:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp45s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:5
    chip-ID: 8087:0aaa class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: yes class-ID: 6c010c
  Local Storage: total: 238.47 GiB used: 79.83 GiB (33.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data
    model: IM2P33F3A NVMe 256GB size: 238.47 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 92209301 temp: 34.9 C scheme: GPT
  ID-1: / raw-size: 195.31 GiB size: 191.19 GiB (97.89%)
    used: 79.73 GiB (41.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 23.13 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p4 maj-min: 259:4
  System Temperatures: cpu: 64.0 C mobo: 60.0 C sodimm: SODIMM C
  Fan Speeds (rpm): cpu: 3584
  Processes: 308 Uptime: 25m wakeups: 0 Memory: total: 16 GiB note: est.
  available: 15.36 GiB used: 9.97 GiB (64.9%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages: 1170
  pm: pacman pkgs: 1161 libs: 282 tools: pamac,yay pm: flatpak pkgs: 5
  pm: snap pkgs: 4 Shell: Zsh v: 5.9 running-in: terminator inxi: 3.3.31

Do you really need to use the latest kernel? I know that EOS is a rolling distro but most people can simply use the LTS one.


Probably no. Is there any automatically way to stop update to the latest kernel versions or core packages?

The easiest way is to install the LTS one, edit your bootloader to boot with it and keeping the latest kernel in case you need it one day.

1 Like

I just updated and saw during the update that i got an Error related to “broken pipe”. This has happend before as well (Error message "broken pipe" during system update) This time i just reinstalled kernels before reboot so maybe that saved me. Wonder if that might have happend to you, now causing that issue?

Only by not updating. That’s not how Arch works. It’s up to date all the time and partial updates are not recommended suggested or supported.

If it works on the lts kernel, you should use it (you should be anyways we just had a thread about this). Other than very select reasons, almost everyone benefits by using the lts kernel over latest.

Otherwise your option is to not update until it’s fixed.

1 Like

I’ve also seen this error 1/2days ago. Rebooting without intervening didn’t cause me any problem (its not a recommendation).

I’m not sure what issue you are talking about here.

There is a newer Bios update for this laptop. Not sure if it would help but is available.
v 1.27.0 12 Dec 2023


Do you have package xf86-video-intel installed?
If so, uninstall it.

1 Like

haha sorry i replied to the wrong guy. Meant OP obviously.

1 Like

Sorry, the xf86-video-intel package is not installed

No need to be sorry, it is a good thing! :wink:
I assume the LTS kernel works for you now.

In case you’ll get new similar issues, it is worth considering the BIOS update that @ricklinux mentioned above.

And welcome aboard! :smile:

Thank you and @ricklinux! I updated the BIOS a few minutes ago :grin: And the LTS kernel worked perfectly. Now I’m trying to integrate the fwupd with de yay updates to keep the BIOS updated.

1 Like

If you want/need to run the “latest and greatest” or “specialized” kernel, It’s always a good idea to have the LTS kernel installed as a fallback in case the other kernel borks on you. In truth, it probably better to just run the LTS kernel unless you have a particular need to run something else.

1 Like

hey how do i chnge to lts kernal can u explain

I guess it still doesn’t work on the current kernel? At the time you were on 6.7.1-arch1-1 It’s updated from that a couple of kernel versions.

You can find that in the wiki of EOS, under How to change the default entry to boot

Are you referring to BIOS? The ‘fwupd’ never worked, now I enable the fwupd-refresh.timer, I hope that start check the BIOS version.

I just install the LTS kernel packages linux-lts and linux-lts-headers, then I create the grub file with sudo grub-mkconfig -o /etc/default/grub. And that’s it, the grub automatically (I guess) list boot options with the kernel version.

mine auto takes me to boot when ever i turn on and then it shows me 2 kernels which i have installed to choose from is it by default like that like it says endeavouros with lts kernal and below the same with newer kernal