Kernel linux-hardened crashes

The linux-hardened kernel crashes after the last update: kernel panic.

pacman -Qs hardened
local/linux-hardened 5.13.13.hardened1-1
The Security-Hardened Linux kernel and modules
local/linux-hardened-headers 5.13.13.hardened1-1
Headers and scripts for building modules for the Security-Hardened Linux kernel

So I had to chroot and reinstall linux-5.13.13

Some Idea?

When does this happen?

reboot immediately after update to linux-hardened 5.13.13.hardened1-1

That’s not massively specific.

When does the kernel panic happen? During the boot process? When reach a graphical target? Is any output shown related to the panic? What do you see if you remove quiet from the GRUB boot parameters? What do you see in the journal for a failed boot (e.g. journalctl -b-1 after booting using linux)?

Yes during the boot process.

Is there any more detail you can provide about this?

If not, the best option will be to wait for the next version (5.13.14) and try again.

You’ve only included the end of the trace, but I can see some references to amdgpu in there. If this is related to the amdgpu driver then it’s likely to be a regression, in which case you can either perform a kernel bisection to identify the specific commit that has caused the issue, or wait for 5.13.14 to see if it will be fixed there.

Yes it seems to be that. Herer is
journalctl -b -2 > kernelpanic.txt
and
journalctl -b -2 | grep -in -A 10 -B 10 amdgpu > kernelpanic-amdgpu.txt
Processing: kernelpanic.txt…
https://asaln.com/paste/?ba1b7a7aa82e2a71#DqmdcQhLoiPL9CffQZdayAk6QfaLe1mXFPYxLovw9ACC

https://asaln.com/paste/?a015117e5c289462#3fjG353FUC8chuxPJADXy7ZrvQN136qqFhtZorX9Jhqh

Edit: I can confirm that the current hardened kernel immediately goes into a kernel panic & doesn’t load on boot.

1 Like

I know that with AMDGPU theres some stuff you need to do when using linux hardened. I cant be sure if thats the cause but ill see if i cant find the tips for it im thinking of.

Its being discussed on the arch forums also https://bbs.archlinux.org/viewtopic.php?id=269155&p=2

EDIT: dont go there and add a report though if using EOS as thats frowned upon afaik

try adding debugfs=off to your kernel cmdline to see if it helps