Kernel issue, boot (most) only with Fallback version

In my Dell Latitude5500 I am most of the time (not always, about 4/5 of the time) stuck at grub when I choose to boot the regular (not fallback initframe) kernel. The ramdisk does not load,
With the fallback there is no issue, either with the last Kernel, the Zen or the LTS, but I am trying to understand what causes this.
My Hook is : `HOOKS=“base udev autodetect modconf block keyboard keymap filesystems fsck”
Any idea how to debug this ?

it should be fsck then filesystems at end ( change order )

have you updated grub recently ?
there is new version for security

Does it give an error message?

I constantly update the system, and this is a new fresh installation made yesterday (coming from Manjaro). Grub is 2:2.04.7
Do you advice to get rid of the fsck ?

Yes, it says:

loading kernel linux ...
loading initial ramdisk ...

And that’s it. Ican only press the on/off button to make an hard reboot and choose the fallback kernel the next time.

I see now your advice to change the order at the end of the line… will try this

Nope, I have switched the last 2 arguments of the Hook line and reconfigured the grub. Same…

all pacnew has been done ?

also have you done :
sudo mkinitcpio -p linux-lts
sudo mkinitcpio -p linux-zen

Done now, but when I run sudo mkinitcpio -p [kernel name] I got 2 warning, maybe related ?:

===> WARNING: Possibly missing firmware for module: wd719x
===> WARNING: Possibly missing firmware for module: aic94xx

no i have theses warning

Nope… still no change :neutral_face:. It’s not the end of the world as I can boot with the fallback, but it’s strange…
I need to go to sleep now :upside_down_face: Will continue tomorrow… Thanks anyway !

i hope this is not coming from sectors disks
may be check this partition /boot