Kernel-install generates wrong configs (ALHP repo)

Het guys, after last update the system didn’t boot, the only boot option was “reboot into firmware interface”. I chrooted into the system from a live cd and apparently linux and initrd paths now have an extra /efi in the front???, i changed /efi/loader/entries/*.conf to not include /efi and now system boots, but after running kernel-install it stops booting again. Is there some sort of config I can change to not include the extra /efi ?

This is autogenerated config which does not boot:

After removing extra /efi it boots:

bootctl spec says that the path is resolved from mountpoint root, so it should not add that extra /efi (/dev/sda1 is mounted to /efi)

1 Like

Where is your systemd package coming from?

Someone else had this same problem yesterday and the issue was because there were getting their systemd package from the ALHP repo.

I am in fact using ALHP repos, but i don’t think they have systemd
Seems like I have a regular systemd

That isn’t actually what that means. There is no way to see where a package was installed from.

Try installing the arch version explicitly.

sudo pacman -S core/systemd
  1. Reinstalled systemd from core
  2. Reinstalled linux to trigger kernel-install
  3. Still broken (

Maybe I should disable ALHP entirely?

You may need to reboot after reinstalling systemd.

I am not sure this will boot

No, it probably won’t. You can edit it so it is correct, reboot and then try again.

I had the same problem.
Edit the file, revert to standard arch and wait for ALHP to fix it.

Ok, so after rebooting and reinstalling linux it’s still the same thing, systemd is definitely from arch :neutral_face:

I have the exact same problem. Just remove the /efi/ prefix in our /efi/loader/entries/*.conf
There should be no path
   /efi/loader/entries  cat 70c74eda65ce4814be68c45b2fee4edf-6.2.8-zen1-1-zen.conf  :heavy_check_mark:
title EndeavourOS
version 6.2.8-zen1-1-zen
machine-id 70c74eda65ce4814be68c45b2fee4edf
sort-key endeavouros-6.2.8-zen1-1-zen
options nvidia-drm.modeset=1 nvme_load=YES rw root=UUID=7560cfaa-bc1a-4f03-8827-a736bdbc0bc9 systemd.machine_id=70c74eda65ce4814be68c45b2fee4edf
linux /70c74eda65ce4814be68c45b2fee4edf/6.2.8-zen1-1-zen/linux
initrd /70c74eda65ce4814be68c45b2fee4edf/6.2.8-zen1-1-zen/initrd

Yeah, i did that, but autogenerated config is still broken, maybe I’ll just wait for next systemd update

Did you update with
pacman -Syuu


I am not sure exactly what is causing the issue. However, it seems to only impact people who are using ALHP.

It is possible it is a different package.

Can you share your /efi/loader/entries/*.conf ?
I can easily reproduce it as soon as I switch to ALHP and update everything to that repo
and update kernel.

title      EndeavourOS
version    6.2.8-arch1-1.1
machine-id 6894bdaf5c064ef7b1aa20941716a43f
sort-key   endeavouros-6.2.8-arch1-1.1
options    root=UUID=96983021-de27-4afb-8ec2-2905778e3a1a rw nowatchdog nvme_load=YES reboot=bios mitigations=off resume=UUID=b79f103b-b242-432a-9c75-51cab48566cb quiet loglevel=3 splash vt.global_cursor_default=0 systemd.machine_id=6894bdaf5c064ef7b1aa20941716a43f systemd.machine_id=6894bdaf5c064ef7b1aa20941716a43f
linux      /6894bdaf5c064ef7b1aa20941716a43f/6.2.8-arch1-1.1/linux
initrd     /6894bdaf5c064ef7b1aa20941716a43f/6.2.8-arch1-1.1/initrd

I am almost 100% certain that if you switch to ALHP now and reinstall kernels it will show the wrong path again

This happens on 2 physical PCs I tried this on

I does that now, I edited out the /efi