Kernel 5.16.1 and 5.16 Not working

I updated my kernel. After that I rebooted my system. now stuck on Loading initial ramdisk at boot.
Used chroot on live iso to install lts kernel it worked but every 5.16 kernel just stuck on there.
I also tried a fresh install still same results.Dont Know Why.

My specs

CPU: Intel Xeon E3-1220-V3
RAM: DDR3 dual channel 8GB 1600MHZ
GPU: Nvidia GTX 1050TI 4GB
Storage: SSD SATA3 256GB

Welcome to :enos: forums.

So you can boot into enos using the lts kernel? but the normal kernel is not working.



5.16 is still pretty new, so there might be problems with it. I would use LTS for now.

Unless you have a really good reason to use the latest mainline kernel (for example, having new hardware), generally, it’s a good idea to use LTS. There is less stress that way.


i searched the internet no one got this problem in this kernel i dont know why this happend

Such things are not uncommon with new kernel releases.

That’s why LTS exists.

Just keep using the LTS kernel and you’ll be fine. Welcome to the forum, btw!


Ok then lts is the defualt for now then. thnx

1 Like

Next time 5.16 gets an update, after updating, try to boot into it to see if they fixed it. If not, stick to LTS.

In fact, even when 5.16 works fine (which, eventually, it probably will), it’s still a good idea to stick to LTS, unless you have a good reason not to.


I got the recommendation during install to stick with LTS kernels and I haven’t had a hardware issue at all.

1 Like

I wish this was better documented. I wouldn’t even know where to put it though.

The only people that should not use the LTS in my opinion - anyone with extremely new hardware, or anyone who knows they want something specific and why (zen or hardened for instance).

LTS for everyone!


Do you think LTS Headers should be installed by default during the installation process and users being told to switch to latest kernel only if required?

No. I think that’s not who the ntended audience is. People should know that by the time they get here.

It’s already been added to the installation media. You just gotta check it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.