Kernel 5.11.2 Freeze on init ramdisk

Hi to all!!
I have an Hp 255 g6 with amd stoney - endeavour plasma with amdgpu mounted
AS written in title, the new kernell freeze on init ramdisk, without debuggin (I’ve already tried erasing ‘quiet’ and addin ‘debug’ or ‘verbose’ in kernel, but nothin wrote on)
I also tried writin in kernel ‘acpi=off’ and it not recognize UUID dev
amd-ucode is already up to date
On the contrary, launchin lts kernel, everything works fine.
I zipped kernels in different ways: LTS in gzip and k5.11.2 in xz
any suggestion?
Thanks in advance

Welcome to the forum :balloon::tada:.

Since linux-lts works, keep using it until 5.11 gets updated again and then give it another try.

1 Like

Thank a lot!!! I’ll wait, then. I’ll let the post open 'till new update.

Nope,f****!! Same errors with k 5.11.4.
I’ve already check UIID in etc/fstab and it’s correct, same in grub…
Could be problem with amd-ucode.img?
or I have to change compression type from xz to zstd?
Can’t figure it out
p.s. Installing xfce de worked fine with k 5.11

Ok, I got it!!! Googlin around I found a new trick: disabling iommu from the grub, nor from Bios
I added “iommu=soft” under “linux” in grub and now all is working with the zen kernel

here is where I found it:
https://bbs.archlinux.org/viewtopic.php?id=264483